tgz vs gz-fil problematikk. Squeezebox Server på Qnap.

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 1 av 2 1 2 SisteSiste
Viser resultater 1 til 20 av 25
  1. #1
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    tgz vs gz-fil problematikk. Squeezebox Server på Qnap.

    I ren frustrasjon (og forbannelse) starter jeg en egen tråd for dette problemet. Har spurt i min egen tråd (før) og en annen tråd (før og i dag) uten å få til en løsning på dette.


    Saken er at jeg vil laste ned siste versjon av Squeezecenter (nå kalt Squeezebox Server versjon 7.4) til min Qnap 219. I det jeg høyreklikker for å laste ned tgz-versjonen står det at det er en tgz-fil, men når nedlastingssiden dukker opp er det plutselig gz-fil..... Forbanna merkelig, og det skaper store problemer for meg.

    Jeg prøver å forandre filnavn ved å klikke på filen. Legger den i Public på Qnap, og går inn i flipflip "sin versjon" på min Qnap. Der, under "Install SqueezeCenter Tar Ball", finner jeg bare den versjonen som jeg har kjørt siden starten. 7.3.2.

    Hva i alle dager gjør jeg feil?
    Jeg HATER mobilversjoner av nettsider...

  2. #2
    Intermediate
    Medlem siden
    Mar 2007
    Poster
    3,119
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Her er det på tide med en kjapp innføring i unix-filosofi, tror jeg

    På unix er det en filosofi at programmer skal gjøre så lite som mulig, og gjøre dette så godt som mulig (det var i hvert fall dette i gamle dager). Derfor gjøres arkivering og komprimering av to forskjellige programmer. I Windows er man gjerne vant til at begge deler gjøres av ett og samme program, som f.eks. rar eller zip, men slik er det altså ikke på unix.

    tar (forkortelse for tape archive) er programmet som slår sammen mange filer til en. Det komprimerer ikke i det hele tatt, så du ender opp med en fil som er bittelitt større enn alle filene du arkiverer tilsammen. Normal filendelse for tar-filer er .tar

    gzip (forkortelse for gnu zip) tar seg av komprimering. Den kan kun komprimere en og en fil. Normal filendelse for gzip-komprimerte filer er .gz

    Vanligvis vil du bruke begge programmene, slik at du f.eks. kan komprimere en hel katalog. Da kan du enten bruke tar først, og så komprimere tar-filen med gzip, eller så kan du la tar kalle opp gzip selv.


    Så tilbake til problemet ditt. Når man har ett sett med filer som er arkivert med tar, og deretter komprimert med gzip, så er det vanlig å gi filen filendelsen .tar.gz eller .tgz. Du sier at filen bare heter .gz, men jeg mistenker at den egentlig ender på .tar.gz. Hvis installasjonsprogrammet ikke klarer å finne ut at dette er det samme som .tgz, så ville jeg bare renama filen og prøvd igjen.

  3. #3
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Føler jeg har gjort alt mulig rart uten hell. Nå ligger det en fil som ender på tgz i Public på Qnap-en, men SSOTS finner ikke denne, og da får jeg heller ikke oppdatert....
    Jeg HATER mobilversjoner av nettsider...

  4. #4
    Expert
    Medlem siden
    Sep 2003
    Poster
    7,881
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Du må vel pakke den ut før du får kjørt den... "tar -zxvf file.tar.gz" eller noe slik om det finnes kommando linje i den boxen da .

  5. #5
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sier meg dessverre ingenting....
    Jeg HATER mobilversjoner av nettsider...

  6. #6
    Newcomer
    Medlem siden
    Aug 2008
    Poster
    159
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hvor fikk du tak i den filen egentlig? Når jeg prøver å laste ned fra logitch sin side kommer det bare at siden/filen ikke eksisterer. "Windows" filen funker dog å laste ned.

    EDIT: Da har jeg funnet fil, og sliter herved med det samme som Teddy... Æsj.

  7. #7
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Mulig løsningen ligger i det som er nevnt over, men jeg er ikke kar om å skjønne det hvertfall. Noen som har oppdatert SC på Qnap som kan gå gjennom dette skritt for skritt? Og ikke anta at jeg forstår noe som helst når det kommer til data. For det gjør jeg ikke.

    Som nevnt så kjører jeg Vista på pc-en om det har noen betydning...
    Jeg HATER mobilversjoner av nettsider...

  8. #8
    Intermediate
    Medlem siden
    Mar 2007
    Poster
    3,119
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har dere prøvd noen av tgz-filene her:

    Index of /SqueezeboxServer_v7.4.0

  9. #9
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Det er den eneste plassen jeg får tak i den, så ja.

    Om jeg går den "vanlige" veien via logitech, så får jeg opp en feilmelding...
    Jeg HATER mobilversjoner av nettsider...

  10. #10
    Newcomer
    Medlem siden
    Sep 2007
    Poster
    34
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av teddytusen
    Mulig løsningen ligger i det som er nevnt over, men jeg er ikke kar om å skjønne det hvertfall. Noen som har oppdatert SC på Qnap som kan gå gjennom dette skritt for skritt? Og ikke anta at jeg forstår noe som helst når det kommer til data. For det gjør jeg ikke.

    Som nevnt så kjører jeg Vista på pc-en om det har noen betydning...
    Jeg kjører Linux Mint og lastet ned en .deb fil herfra: My Music - Welcome to mysqueezebox.com!

  11. #11
    Newcomer
    Medlem siden
    Nov 2005
    Poster
    79
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av teddytusen
    Det er den eneste plassen jeg får tak i den, så ja.

    Om jeg går den "vanlige" veien via logitech, så får jeg opp en feilmelding...
    Squeezebox Server 7.4 fungerer foreløpig ikke med den Qnap-disken du nevner. Jeg har selv TS-119, og der er 7.3.4 siste versjon som funker.

    Du må vente til SSOTS (det underliggende programmet som gjør det mulig å kjøre Squeezecenter, som det het før) oppdateres før 7.4 funker.

    Sjekk på forumene til Qnap for mer info.

  12. #12
    Expert teddytusen sin avatar
    Medlem siden
    Dec 2005
    Sted
    Nordfjord
    Poster
    8,659
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Aha!!!! Det forklarte det hele gitt. Takk for den oivindi.

    Fikk oppgradert til 7.3.4 nå.

    Renama filen til tgz og copy/paste til Public. Funket med en gang.

    Hvilken versjon av SSOTS er den siste, og hvor finner jeg den? Er det enkelt og greit å oppdatere den? Har 3.15 nå.
    Jeg HATER mobilversjoner av nettsider...

  13. #13
    Active mikkel rev sin avatar
    Medlem siden
    Oct 2007
    Poster
    345
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har et problem med mitt oppsett. Sliter med å få inn musikk rett fra Qnap'en. Har forsøkt å sette inn IP-adressen til QNAP'en under Bibliotek, men får da bare feilmelding Kan ikke koble til trådløst nettvrk. Skjønner ikke hva jeg gjør galt, da jeg får logget på mitt trådløse nettverk. Noen som har noen tips om hvordan sette opp Squeeze-boksen for å hente musikk rett fra Qnap og slippe å hente musikk via PC?? Versjon jeg bruker er 7.3.3

  14. #14
    Newcomer
    Medlem siden
    Sep 2009
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av oivindi
    Squeezebox Server 7.4 fungerer foreløpig ikke med den Qnap-disken du nevner. Jeg har selv TS-119, og der er 7.3.4 siste versjon som funker.

    Du må vente til SSOTS (det underliggende programmet som gjør det mulig å kjøre Squeezecenter, som det het før) oppdateres før 7.4 funker.

    Sjekk på forumene til Qnap for mer info.
    Mulig dere har funnet ut av det men jeg gjorde meg to erfaringer.

    1) Nedlasting via IE ga de feilmeldingene beskrevet over, mens nedlasting av samme fil via Qnap sin download manager fungerte perfekt. Anntar at http-nedlastningen i IE gjør noe med fila... :-(

    2) Den andre erfaringen var at SSOTS forventer en fil som heter squeezecenter, mens 7.4 og oppover heter squeezeboxserver. Rename til gammel 'semantikk' så finner SSOTS fila :-)

  15. #15
    Newcomer
    Medlem siden
    Sep 2009
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av mikkel rev
    Har et problem med mitt oppsett. Sliter med å få inn musikk rett fra Qnap'en. Har forsøkt å sette inn IP-adressen til QNAP'en under Bibliotek, men får da bare feilmelding Kan ikke koble til trådløst nettvrk. Skjønner ikke hva jeg gjør galt, da jeg får logget på mitt trådløse nettverk. Noen som har noen tips om hvordan sette opp Squeeze-boksen for å hente musikk rett fra Qnap og slippe å hente musikk via PC?? Versjon jeg bruker er 7.3.3
    Når du kobler Squeezeboxen på nettet velger du Qnap-en og ikke PC-en som Squeezebox server. Kan virke som at du er koblet til PC-en først og forsøker å koble til Qnap-en derfra?

  16. #16
    Active mikkel rev sin avatar
    Medlem siden
    Oct 2007
    Poster
    345
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Det kan hende vi har gjort det ja ! Vi legger inn software på nytt og ser om vi får endret da !

  17. #17
    Active mikkel rev sin avatar
    Medlem siden
    Oct 2007
    Poster
    345
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Får det fremdeles ikke til vi :-( Ingen som har en oversikt over hvordan det skal installers fra bunnen av ? Dvs. oppsett Squeezecenter + Duet fjernkontroll ?

  18. #18
    Newcomer
    Medlem siden
    Sep 2009
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av mikkel rev
    Får det fremdeles ikke til vi :-( Ingen som har en oversikt over hvordan det skal installers fra bunnen av ? Dvs. oppsett Squeezecenter + Duet fjernkontroll ?
    Jeg sitter med "classic" (dvs. v3) så det er ikke sikkert at fremgangsmåten er helt lik. Regner med du har installert SSOTS og en eller anne versjon av Squeezecenter på Qnap i henhold til bruksanvisningen på Qnap/QPKG/SSOTS sine sider og verifisert at denne kjører?

    I så fall er det slik hos meg at hvis jeg tar strømmen på Squeezeboxen så kjører den nettverksoppsettet på nytt. Når jeg da kommer til "koble til Squeezecenter" kan jeg velge mellom to servere, PC-en min (bare fordi den fortsatt går og jeg ikke har giddet å stoppe den, som kanskje kunne være en idé for å hindre at den blir valgt automatisk) og Qnap-en. Velger da den siste.

    Ga dette noen mening?

  19. #19
    Newcomer
    Medlem siden
    Sep 2007
    Poster
    3
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Installerte 7.4 på Qnap nå, og fikk beskjed at alt var installert riktig. Skulle starte squeezecenter igjen men får beskjed om at det ikke går og at "The log file might reveal the reason for the failure." Det sier ikke meg noe, og jeg lurer på hva som kan være galt...

  20. #20
    Newcomer
    Medlem siden
    Sep 2007
    Poster
    3
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Gikk tilbake til 7.3.4 versjonen og det gikk fint, men versjon 7.4 funker ikke. Det er tgz fil, og jeg har gitt den nytt navn som nevnt her tidligere. Det gjorde at den dukket opp under "Upgrade Squeezecenter" som tidligere har vært et problem. Derfor trodde jeg at alt var i orden, og det indikerte også instalasjonen.

    ps: min Slimserver på Qnapen er 3.15. Den er gammel regner jeg med. Hvor finner jeg en nyere versjon?

Side 1 av 2 1 2 SisteSiste

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •