Installer XBMC Media Center - Side 5

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 5 av 8 FørsteFørste 1 2 3 4 5 6 7 8 SisteSiste
Viser resultater 81 til 100 av 153
  1. #81
    Intermediate b-ill sin avatar
    Medlem siden
    Feb 2005
    Poster
    972
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Nå ser alt ut til å ha godt greit med scriptet, sudo kommandoen funket ikke tidligere pga jeg tillot root tilkobling.

    Jeg fikk kjørt scriptet og det så ut som det avsluttet greit. Jeg tok en 'sudo shutdown -r now' den bootet fint og jeg så XBMC logoen et par ganger. og logget meg på igjen med xbmc, kom så inn til xbmc@HTPCstue:~$ hvor jeg skrev 'xbmc' og fikk da dette:

    xbmc@HTPCstue:~$ xbmc
    Error: unable to open display
    FEH.py: cannot connect to X server
    xbmc@HTPCstue:~$

    Og nå blinker skjermen hvert 10 sekund, hva skjer?

    Edit1: Jeg prøver på nytt -holder på med å installere scriptet nå..

    Edit2: Ikke forandre på noe under installasjonen, så vil det funke Trykk [enter] på alt. Når den spør om du vil aktivere root innlogging, gjør ikke det, så oppretter du en konto med brukernavnet 'xbmc' i stedet og gir den et passord. Da vil også 'sudo' kommandoen gå greit. Det meste funker nå, xbmc starter automatisk og jeg har fått lagt til filmbiblioteket mitt som er på en server. Men lyder får jeg ikke til å funke. Asrock står oppkoblet med HDMI mot en Panasonix px-80 plasma. Jeg har ikke noe navigeringslyd og ikke noe film lyd, uansett film jeg kjører. Har prøvd å forandre på 'Settings - System - Audio Hardware' uten hell. Har tom oppdatert til siste bios 1.6.

    1080p, 720 filmer hakker også. Må jeg aktivere vdpau selv noen steder?

    Edit3: La til vdpau i RenderingMethod og når går det smoothere. Er nesten så fuglescenen i Earth også går perfekt. Men har ikke fått til noe lyd.

    Edit4: Nå funker lyden også, jeg må gå inn på alsamixer(ctrl+alt+F2, så logger du deg inn på 'xbmc' kontoen din og skriver bare alsamixer) blar deg til høyre og trykker på knappen 'm' på hver av søylene slik at dem bli grønne i bunnen. I 'Settings - System - Audio Hardware' tok en analog og plug:hdmi og enablet den nederste. Nå funker alt.

  2. #82
    Newcomer
    Medlem siden
    Jun 2004
    Poster
    124
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Kan jeg bruke denne fremgangsmåten for og innstallere på en MAC MINI!! Svar fort, da jeg holder på å laste ned nå Og er det kommet en løsning for å få spotify til og fungere opptimalt??

  3. #83
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    19
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av jiframnes
    Kan jeg bruke denne fremgangsmåten for og innstallere på en MAC MINI!! Svar fort, da jeg holder på å laste ned nå Og er det kommet en løsning for å få spotify til og fungere opptimalt??
    Hei.

    Kanskje ikke så fort som du ønsket, men men..

    Jeg hadde nok anbefalt Plex Media Center til din Mac Mini.
    Dette er så og si en identisk kopi av XBMC som er spesialtilpasset Mac.

    + Fordelen er at Plex kan virke litt mer stabil og enklere enn XBMC.

    - Ulempen er at du har ikke like mange muligheter til å forandre systemet på som XBMC, og at XBMC har en definitivt mye større brukergruppe - hvorav et større "støtteapparat"

    Lykke til!

  4. #84
    Newcomer
    Medlem siden
    Jun 2004
    Poster
    124
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Mac mini

    Prøvde fremgangsmåten din å fikk installert ubuntumini. Men når jeg skulle bruke koden for å installere XBMC, så fikk jeg feilbeskjed. Den samme feilbeskjeden som en har lagt inn bilde av i tråden din på xbmc-forumet.. Så når har jeg installert ubuntu 9.10, men det er ikke kommet en utgave av xbmc enda som støtter dette perfekt enda. Eller kan jeg legge inn XBMC stable 9.04?? Er fremdeles usikker på om hvordan jeg ska gjøre dette, eller om jeg bare skal kvitte meg med møkk'en og kjøpe asrock... Kjører den lyd over HDMI og i tilfelle ja, de nye lydformatene??

  5. #85
    Newcomer
    Medlem siden
    Nov 2009
    Poster
    3
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Feil i autoscriptet ?

    Hei.

    Har med lykke klart å installere dette på en Asrock i Oktober, men nå i November sliter jeg med Asrock nr 2. Gjør akkurat det samme som i Oktober, men den feiler.

    Bruker Ubuntu jaunty miniimage (samme som på asrock nr1).

    Får : "Some packages could not be intalled." + "The following packages have unmet dependencies:
    xbmc-live: Depends: xmbc-standalone (= 9.11~alpha1-jaunty1) but it is not going to be installed
    E: Broken packages
    Terminated

    Om det hjelper prøvde jeg en "sudo apt-get install xbmc-common" som forteller meg at libass3 packagen ikke blir funnet.

    Har noen noe tips her ? Jeg er ganske fersk i linux selv.. forsøker en annen guide nå, men vil gjerne ha tips til å få ordnet denne.

  6. #86
    Newcomer
    Medlem siden
    Nov 2009
    Poster
    3
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Smile

    Sitat Opprinnelig postet av wimpymedia
    Hei.

    Har med lykke klart å installere dette på en Asrock i Oktober, men nå i November sliter jeg med Asrock nr 2. Gjør akkurat det samme som i Oktober, men den feiler.

    Bruker Ubuntu jaunty miniimage (samme som på asrock nr1).

    Får : "Some packages could not be intalled." + "The following packages have unmet dependencies:
    xbmc-live: Depends: xmbc-standalone (= 9.11~alpha1-jaunty1) but it is not going to be installed
    E: Broken packages
    Terminated

    Om det hjelper prøvde jeg en "sudo apt-get install xbmc-common" som forteller meg at libass3 packagen ikke blir funnet.

    Har noen noe tips her ? Jeg er ganske fersk i linux selv.. forsøker en annen guide nå, men vil gjerne ha tips til å få ordnet denne.
    For dere som sliter med dette så fant jeg en fix:
    1) kjør scriptet til det feiler.

    2) kjør: "nano /etc/apt/sources.list" og legg til følgende to linjer i toppen:
    deb Index of /xbmc-addons/ppa/ubuntu jaunty main
    deb Index of /team-xbmc/jaunty-ppa/ubuntu jaunty main

    3) kjør: "apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 318C7509 9317790E"

    4) så kjøres scriptet setupXBMC.sh igjen og alt skal fungere fint

    Mulig punkt 1 og 2 ikke trengs, men la det til siden det var det jeg gjorde.

    Virker som det er en hash "feil" eller noe grunnet overgang til nyeste xbmc (9.11 alpha) som kom veldig nylig.

    PS.. dette er nok en "dirty fix" som ikke lander godt hos linux vante folk, men funka for meg i nattestimene :-D

  7. #87
    Newcomer
    Medlem siden
    Oct 2005
    Poster
    226
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av ErikX
    Takk for svar Kane. Tror imidlertid ikke dette er et nettverksproblem. Jeg har en HDX-1000 som streamer fra samme NAS, og den gjør det uten problemer. Vet heller ikke om noen HD filmer som krever bitrate over 100 Mbit.

    Noen her som har testet med Planet Earth 1080p mkv og fått den til å spille problemfritt?

    EDIT: Skal prøve å kopiere den over til lokal harddisk å spille den via MCP-HC under Windows 7 for å komme til bunns i om dette er et nettverksproblem.

    EDIT2: Steike! Du hadde rett Kane! No problem med Planet Earth når jeg spilte den fra lokal harddisk. Tenker jeg går til anskaffelse av en ekstern 1 TB USB disk som jeg kobler direkte på Asrocken. Det bør vel gjøre susen. Kudos til deg Kane! :-)

    EDIT3: Issue 3 solved. Kan aksessere lokal disk ved å fjerne "nodiskmount" fra menu.lst.

    Da gjenstår kun issue 1. Anyone?
    Fikk du playbacken helt smooth, eller? Jeg sliter litt med det samme. Har vel bortimot sammme hardware som deg, ION chipset med 1,6GHz Atom dualcore (klokket til 2,0GHz, riktignok), og jeg synes ikke f.eks. Planet Earth går så smooth som det bør gjøre.
    Ser det spesielt godt på ep.1@1:10, der de flyr mellom to fjell (rett før fuglescenen). Det går _nesten_ helt smooth, men man ser at det hakker.
    vq ligger på 90-99% under disse scenene.
    Streamer vanligvis fra en annen linux-boks, men har prøvd å kopiere over fila og kjøre den lokalt også, uten forskjell.

    Ideer mottas med takk

    PS. Skulle gjerne prøvd å spille av Planet Earth BD'en, for å se om det er bedre, men siden linux-brukere blir nektet å spille av lovlig anskaffede plater (og dermed blir tvunget til å laste ned filmene istedet) så har jeg ikke fått testet det..

  8. #88
    Newcomer
    Medlem siden
    Jan 2007
    Poster
    158
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Ser at denne guiden installerer uten desktop på ubuntuen. Eller misforstår jeg helt?

    Lurer litt på dette da jeg har lyst til og kunne bruke den som en "vanlig" pc. Og da ikke nødvendig at den booter rett i XBMC.
    Har hørt at Ubuntu er det som skal være mest likt windows. Derfor tror jeg at jeg vil gå for dette. For er interessert i å kunne surfe nettet og andre div ting, som kjøre en liten server for huset etc. Torrents og slikt.

    Er ikke en kløpper i og bruke ubuntu, så derfor litt nysgjerrig også.

    Men i hovedsak vil jo maskinen bli brukt til film, av ymse kvalitet, stort sett dvd og bd. Men torrent nedlastning er viktig.

  9. #89
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    73
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Vil bare si takk til trådstarter for å peke meg i retning av det scriptet. Driver nå å mekker med Aeon skinnet. Helt genialt med XBMC på linux, men jeg vil fraråde å bruke ATI skjermkort med mindre du har veldig god peiling på linux

  10. #90
    Intermediate Kane sin avatar
    Medlem siden
    May 2004
    Poster
    3,247
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wimpymedia
    For dere som sliter med dette så fant jeg en fix:
    1) kjør scriptet til det feiler.

    2) kjør: "nano /etc/apt/sources.list" og legg til følgende to linjer i toppen:
    deb Index of /xbmc-addons/ppa/ubuntu jaunty main
    deb Index of /team-xbmc/jaunty-ppa/ubuntu jaunty main

    3) kjør: "apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 318C7509 9317790E"

    4) så kjøres scriptet setupXBMC.sh igjen og alt skal fungere fint

    Mulig punkt 1 og 2 ikke trengs, men la det til siden det var det jeg gjorde.

    Virker som det er en hash "feil" eller noe grunnet overgang til nyeste xbmc (9.11 alpha) som kom veldig nylig.

    PS.. dette er nok en "dirty fix" som ikke lander godt hos linux vante folk, men funka for meg i nattestimene :-D
    Holder på å legge det inn på en ASRock nå. Skal testet "fixen" din. Krysser fingrene å håper det funker.

    Håper også cyberpark oppdaterer guiden sin slik at det funker ( nytt script? ) for dette er en helt genial måte for folk som ikke kan så mye Linux å få ett perfekt mediasenter opp å gå på

    EDIT:

    For å få det til å funke måtte jeg kjøre disse også:

    apt-get install libenca0 libfontconfig1 libfreetype6
    wget https://launchpad.net/~team-xbmc/+ar...xbmc1_i386.deb
    wget https://launchpad.net/~team-xbmc/+ar...xbmc1_i386.deb
    dpkg -i libass3_0.9.6-1xbmc1_i386.deb
    dpkg -i libass-dev_0.9.6-1xbmc1_i386.deb
    rm libass3_0.9.6-1xbmc1_i386.deb
    rm libass-dev_0.9.6-1xbmc1_i386.deb
    Yamaha CX-A5000, Sherbourn PA 5-200, Arendal Sound 1723 Tower, Arendal Sound 1723 Center, 3 x Arendal Sound 1723 SUB3, SVS SSS-01

  11. #91
    Intermediate Kane sin avatar
    Medlem siden
    May 2004
    Poster
    3,247
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Funker fremdeles ikke helt som det skal. Håper der er en smart Linux mann som snart legger ut ett script vi noobs kan bruke for å få ting opp å gå ordentlig igjen.
    Yamaha CX-A5000, Sherbourn PA 5-200, Arendal Sound 1723 Tower, Arendal Sound 1723 Center, 3 x Arendal Sound 1723 SUB3, SVS SSS-01

  12. #92
    Newcomer
    Medlem siden
    Nov 2009
    Poster
    3
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Kane
    Funker fremdeles ikke helt som det skal. Håper der er en smart Linux mann som snart legger ut ett script vi noobs kan bruke for å få ting opp å gå ordentlig igjen.
    Tipper fiksen min kun funka på Alpha 1 releasen. Funka på 2 stk Asrock den dagen jeg la ut posten, men ser at Alpha 2 har kommet så kan være litt endringer da ja.. :/

    Sier ifra om jeg finner et oppdatert script

  13. #93
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av pettergulbra
    Men i hovedsak vil jo maskinen bli brukt til film, av ymse kvalitet, stort sett dvd og bd. Men torrent nedlastning er viktig.
    Ubuntu er ikke å anbefale til avspilling av BluRay... Proprietære forhold gjør at BluRay ikke har støtte i Linux...

  14. #94
    Newcomer
    Medlem siden
    Jan 2007
    Poster
    158
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Glemte og nevne at det da er BD i iso format det er snakk om.

    Petter

  15. #95
    Newcomer
    Medlem siden
    Aug 2009
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Hjelp

    Nå har jeg fulgt denne guiden her og tilslutt fått installert scriptet uten feilmeldinger. Men når jeg booter opp pc'n etter dette så kommer det:

    Starting Hardware abstraction layer hald [ OK ]
    Starting....
    Starting....
    Starting....
    Restarting OpenBSD Secure Shell server sshd

    Her stopper det opp? Alle de andre står det OK på, men på siste linja bare står det stille.

  16. #96
    Newcomer
    Medlem siden
    Nov 2009
    Poster
    2
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Skriptet fungerte ikke for meg i går, men heldigvis dukket det opp ett nytt på XBMC forumet i natt som fungerte helt flott her!

    Kode:
    #!/bin/bash -v
    #------------------------------------------------------------------------------------------------------------
    # setupXBMC Version 0.7a - 18/11/2009
    # XBMC Installation script - by VirtualDanny.net
    # This script will provide an automatic installation of Xbox Media Center
    #
    # REQUIREMENTS:
    # * Clean Ubuntu Jaunty Server Installation (https://help.ubuntu.com/community/In...tion/MinimalCD)
    # * XBMC Compatible Hardware (http://xbmc.org/wiki/?title=XBMC_for_Linux_specific_FAQ)
    # * Internet access
    # * Username must be set to 'XBMC' under Ubuntu installation
    #
    # TO-DO LIST:
    # * Menu to choose from Stable Release or Bleeding Edge Release
    # * Automatic adjustments of all volume channels in Alsamixer
    # * Additional tweaks
    # * Setup common folders and setup simple smbd
    # *  Give option for ATI/Nvidia Driver setup
    #
    # KNOWN BUGS:
    # * Installation will fail if you uncomment SVN Repositories during first time installation.
    #
    # Remember to run this script with: sudo ./setupXBMC.sh
    #------------------------------------------------------------------------------------------------------------
    
    ## --[ Miscellaneous variables ]------------------------------------------------
    
    RELEASE=`cat /etc/lsb-release | grep CODENAME | cut -d = -f2`
    
    cd /
    
    
    ##--[ ADDING REPOSITORIES TO SOURCE LIST ]-------------------------------------------------------------------
    ##    Repositories make it easier to download and stay up-to-date with current releases of Linux applications
    
    echo '#' XBMC Repositories >> /etc/apt/sources.list.d/xbmc.org.list
    echo '#' SVN builds are commented out. Remove comment '#' to enable.  >> /etc/apt/sources.list.d/xbmc.org.list
    echo '#' Please DO NOT use the SVN builds during first time installation  >> /etc/apt/sources.list.d/xbmc.org.list
    echo deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ $RELEASE main >> /etc/apt/sources.list.d/xbmc.org.list
    echo deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ $RELEASE main >> /etc/apt/sources.list.d/xbmc.org.list
    #echo '#'deb http://ppa.launchpad.net/xbmc-addons/ppa/ubuntu $RELEASE main >> /etc/apt/sources.list.d/xbmc.org.list ### Test for Karmic, if so then comment out ###
    
    echo '#'deb http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu $RELEASE main >> /etc/apt/sources.list.d/xbmc.org.list
    echo '#'deb-src http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu $RELEASE main >> /etc/apt/sources.list.d/xbmc.org.list
    
    
    
    ##--[ ADDING NVIDIA REPOISOTIRES TO SOURCE LIST ]------------------------------------------------------------
    
    echo   >> etc/apt/sources.list
    echo '#' NVIDIA Repositories >> etc/apt/sources.list
    echo deb http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu $RELEASE main >> etc/apt/sources.list
    
    
    
    ##--[ ADDING PGP KEYS TO VERFIY VALID SOURCES ]--------------------------------------------------------------
    
    apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 318C7509 64234534 CEC06767 0x6D975C4791E7EE5E
    
    
    
    ##--[ RUNNING A SYSTEM UPDATE ]------------------------------------------------------------------------------
    
    apt-get update
    
    
    
    ##--[ INSTALL GENERIC NVIDIA GRAPHIC DRIVERS ]---------------------------------------------------------------
    
    apt-get install linux-headers-generic nvidia-glx-185 -y
    
    
    
    ##--[ INSTALLS XBMC Media Center ]---------------------------------------------------------------------------
    
    apt-get install xbmc -y
    apt-get install xbmc-skin-* -y
    apt-get install xbmc-eventclients-* -y
    apt-get install xbmc-scripts-* -y
    
    
    
    ##--[ INSTALL XBMC SVN Repo Installer ]----------------------------------------------------------------------
    
    apt-get install unzip -y
    cd /
    cd /home/xbmc/.xbmc/plugins/programs
    wget http://xbmc-addons.googlecode.com/sv..._Installer.zip
    unzip -o SVN_Repo_Installer.zip
    rm SVN_Repo_Installer.zip
    chown -R xbmc:xbmc "SVN Repo Installer"
    
    
    
    ##--[ INSTALL Additional software ]--------------------------------------------------------------------------
    
    apt-get install openbox xterm xinit x11-xserver-utils -y
    
    
    
    
    ## --[ INSTALL AND CONFIGURE ALSA SOUND ]--------------------------------------------------------------------
    
    apt-get install linux-sound-base alsa-base alsa-utils -y
    usermod -a -G audio xbmc
    
    echo
    echo AlsaMixer will now start so that you can configre your volum levels.
    echo 
    echo Press 'M' to activate/deactive, Arrows to adjust volume, and ESC to save/quit.
    echo Press any Key to contiue, or wait 20 seconds to continue
    read -n1 -t20 any_key
    
    alsamixer
    alsactl store 0
    
    
    
    ## --[ INSTALL XBMC Bootscreen ]-----------------------------------------------------------------------------
    
    apt-get install usplash-theme-xbmc-* -y
    update-alternatives --set usplash-artwork.so /usr/lib/usplash/xbmc-splash-spinner-black.so
    echo xres=1024 >> /etc/usplash.conf
    echo yres=768 >> /etc/usplash.conf
    
    update-initramfs -u
    
    
    
    ## --[ INSTALL Linux IR Remote Control Support]--------------------------------------------------------------
    
    #apt-get install lirc -y
    
    
    
    ## --[ FINAL SYSTEM UPGRADE ]--------------------------------------------------------------------------------
    
    apt-get update
    apt-get upgrade -y
    
    
    
    ## --[ GENERATE XORG.CONF ]----------------------------------------------------------------------------------
    
    nvidia-xconfig -s --no-logo --force-generate
    
    
    
    ## --[ ADDING HWcursor fix ]---------------------------------------------------------------------------------
    
    sed -i '40i\    Option         "HWCursor" "False"' /etc/X11/xorg.conf
    
    
    
    ## --[ ENABLE 1080p 24Hz]------------------------------------------------------------------------------------
    
    sed -i '50i\    Option         "DynamicTwinView" "False"' /etc/X11/xorg.conf
    
    
    
    ## --[ Disable Composite for better H264 acceleration ]------------------------------------------------------
    sed -i '30i\Section "Extensions"' /etc/X11/xorg.conf
    sed -i '31i\    Option         "Composite" "Disable"' /etc/X11/xorg.conf
    sed -i '32i\EndSection' /etc/X11/xorg.conf
    
    
    
    ## --[ INSTALLING XBMC HELPERS ]-----------------------------------------------------------------------------
    apt-get install xbmc-live python-apt -y
    
    ## --[ Setup autologin for user "xbmc" ]-----------------------------------------------------------------------------------
    
    if [[ "$RELEASE" == "hardy" || "$RELEASE" == "intrepid" || "$RELEASE" == "jaunty" ]]
    	then
    		echo '# tty1 - getty' > /etc/event.d/tty1
    		echo '#' >> /etc/event.d/tty1
    		echo '# This service maintains a getty on tty1 from the point the system is' >> /etc/event.d/tty1
    		echo '# started until it is shut down again.' >> /etc/event.d/tty1
    		echo >> /etc/event.d/tty1
    		echo 'start on stopped rc2' >> /etc/event.d/tty1
    		echo 'start on stopped rc3' >> /etc/event.d/tty1
    		echo 'start on stopped rc4' >> /etc/event.d/tty1
    		echo 'start on stopped rc5' >> /etc/event.d/tty1
    		echo >> /etc/event.d/tty1
    		echo 'stop on runlevel 0' >> /etc/event.d/tty1
    		echo 'stop on runlevel 1' >> /etc/event.d/tty1
    		echo 'stop on runlevel 6' >> /etc/event.d/tty1
    		echo >> /etc/event.d/tty1
    		echo 'respawn' >> /etc/event.d/tty1
    		echo 'exec /bin/login -f xbmc </dev/tty1 > /dev/tty1 2>&1' >> /etc/event.d/tty1
    elif [ "$RELEASE" == "karmic" ]
    	then
    		echo '# tty1 - getty' > /etc/init/tty1.conf
    		echo '#' >> /etc/init/tty1.conf
    		echo '# This service maintains a getty on tty1 from the point the system is' >> /etc/init/tty1.conf
    		echo '# started until it is shut down again.' >> /etc/init/tty1.conf
    		echo >> /etc/init/tty1.conf
    		echo 'start on stopped rc RUNLEVEL=[2345]' >> /etc/init/tty1.conf
    		echo 'stop on runlevel [!2345]' >> /etc/init/tty1.conf
    		echo >> /etc/init/tty1.conf
    		echo 'respawn' >> /etc/init/tty1.conf
    		echo 'exec /bin/login -f xbmc </dev/tty1 > /dev/tty1 2>&1' >> /etc/init/tty1.conf
    fi
    
    echo 'case "`tty`" in' > /home/xbmc/.bash_profile
    echo '/dev/tty1) clear && startx &>/dev/null;;' >> /home/xbmc/.bash_profile
    echo 'esac' >> /home/xbmc/.bash_profile
    
    echo exec openbox-session > /home/xbmc/.xinitrc
    
    mkdir -p /home/xbmc/.config/openbox
    
    echo '#!/bin/bash' > /usr/local/bin/xbmc-session
    echo >> /usr/local/bin/xbmc-session
    echo 'until xbmc --standalone; do' >> /usr/local/bin/xbmc-session
    echo	'echo "uh oh xbmc crashed with code $?... restarting it" >$2' >> /usr/local/bin/xbmc-session
    echo 	'sleep 5' >> /usr/local/bin/xbmc-session
    echo 'done' >> /usr/local/bin/xbmc-session
    
    chmod +x /usr/local/bin/xbmc-session
    
    echo xbmc-session > /home/xbmc/.config/openbox/autostart.sh
    
    chown -R xbmc:xbmc /home/xbmc
    		
    	
    	
    #SYSTEM Reboot
    sync
    /sbin/reboot
    Sitat Opprinnelig postet av biptn
    NOTES
    I have tested this with Karmic minimal on an Acer Revo R1600. It needs to be tested with other versions, there are still some nice little options for ATI or NVIDIA, stable or bleeding edge also to do. I (or someone elase) has to add the extras repo back in for the supported versions.

    ADDITIONS
    I've added autologin features, so once it reboots you'll be dropped right into XBMC, I would like to fix that part so if for some reason xbmc segfaults it will automatically be re-launched. The script now determines the version of ubuntu running and adds the correct repos.
    Stor takk til cyberpark for å ha satt i gang dette, lenge sett etter en billig og grei HTPC løsning, og dette er midt i blinken!

  17. #97
    Newcomer
    Medlem siden
    Jun 2006
    Poster
    66
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hei!

    Har tenkt til å sette opp en PC jeg har her som media center. Men jeg lurer på om den er kraftig nok til å spille av 720p? 1080p kommer nok til å ikke gå så bra er jeg redd, PCen er jo noen år stakkars.

    Hadde planer om å sette opp MediaPortal, men har mer lyst til å prøve XMBC nå.
    Er det bare å installere linux + XMBC som i denne guiden? Hvordan fungerer disse Asrock ION330'ene med HD-film?

    Har litt film og serier som er lastet ned, hvordan er det med å få det over på XMBC hvis den kjører på linux?

    Edit:
    Har muligheten til å kjøre dette på den stasjonære PCen, Asrock ION330, Xbox 360 eller en HP 6530b laptop.
    Fordeler, ulemper?

  18. #98
    Intermediate DrErling sin avatar
    Medlem siden
    Oct 2003
    Poster
    4,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    De fleste rapporter jeg har lest om folk som "har fått det til" på asrock ION330 er positive. Grunnen til "fått det til" i klammer er at mange sliter med å finne rett guide, samt gjøre denne i riktig rekkefølge.

    Jeg har ingen betenkeligheter mot å kjøpe de nye dual core utgavene av ION330 maskiner med tanke på avspilling av 1080p.

    Eneste jeg reagerer på i sistnevnte script er nvidia-driveren (185). Det er vel dokumentert bedre ytelse i VDPAU på 191-driverne fra nvidia? De fleste guider jeg har lest tar i bruk de nyeste driverne fra nvidia.

    DrE

  19. #99
    Newcomer
    Medlem siden
    Sep 2009
    Poster
    42
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av DrErling
    De fleste rapporter jeg har lest om folk som "har fått det til" på asrock ION330 er positive. Grunnen til "fått det til" i klammer er at mange sliter med å finne rett guide, samt gjøre denne i riktig rekkefølge.

    Jeg har ingen betenkeligheter mot å kjøpe de nye dual core utgavene av ION330 maskiner med tanke på avspilling av 1080p.

    Eneste jeg reagerer på i sistnevnte script er nvidia-driveren (185). Det er vel dokumentert bedre ytelse i VDPAU på 191-driverne fra nvidia? De fleste guider jeg har lest tar i bruk de nyeste driverne fra nvidia.

    DrE
    Det er vel mulig å redigere skriptet til å hente 191 driverne fra NVidia i stedet for 185?
    Jeg sliter med at på min HTPC (Zotac 330 ION) så hakker 1080p filmer jevnt. Kanskje det har noe med driverne å gjøre? (Ja VDPAU er aktivisert, hvis noen lurer på det.)
    Jeg bruker Western Digital HD TV live boks for å se 1080p filmer og der fungerer de utmerket.

    Kanskje cyberpark kan ordne skriptet til å bruke 191 driverne i stedet for 185, hadde vært greit for meg å prøve, da jeg har et lite problem.

    PS, skriptet kunne kanskje også vært oppdatert for XBMC 9.11 Alpha 2?

  20. #100
    Intermediate DrErling sin avatar
    Medlem siden
    Oct 2003
    Poster
    4,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av King Canute
    Det er vel mulig å redigere skriptet til å hente 191 driverne fra NVidia i stedet for 185?
    Jeg vil regne med at det er bare å redigere scriptet selv ja. Liten skriveleif fra min side, siste drivere er 190.42 og driverne ligger her.

    Hvis ikke så går det sikkert brillefint å legge de inn manuelt etterpå. Tviler på at man trenger å oppdatere sources.list (men ikke 100% sikker)

    Kode:
    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 71609D4D2F1518FA9C5DC0FB1DABDBB4CEC06767
    
    sudo apt-get update
    sudo apt-get install linux-headers-generic nvidia-glx-190
    sudo reboot
    
    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)
    
    sudo reboot
    Bør bekreftes av noen som vet hva de snakker om. Jeg har bare spurt google. :wink:

    DrE

Side 5 av 8 FørsteFørste 1 2 3 4 5 6 7 8 SisteSiste

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •