Dolby Digital og DTS test-toner fungerer ikke i Vista

Sponsorer:
Takk Takk:  0
Like Like:  0
Viser resultater 1 til 19 av 19
  1. #1
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Dolby Digital og DTS test-toner fungerer ikke i Vista

    Hei, jeg har et problem jeg har slitt med en stund nå.. er faktisk så lei at jeg vurderer å kjøpe nytt hovedkort i håp om at det vil løse problemet.

    Problemet er at jeg ikke får sendt DD/DTS signal fra pc til receiver (via SPDIF), når jeg høyreklikker på lyd ikonet i høyre hjørne på oppgavelinjen og velger egenskaper på "Realtek digital output", og deretter tester DTS/DD får jeg bare et lite knepp i receiveren, men ingen lyd..

    Men problemet kan ikke være receiveren da den tar i mot både Stereo over samme SPDIF kabel, og den tar i mot DD/DTS fra DVD spilleren over en annen SPDIF kabel.

    Er det noen som kan ha noen tips til hva som er galt?

  2. #2
    Newcomer
    Medlem siden
    Feb 2007
    Poster
    86
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av nonames
    Hei, jeg har et problem jeg har slitt med en stund nå.. er faktisk så lei at jeg vurderer å kjøpe nytt hovedkort i håp om at det vil løse problemet.

    Problemet er at jeg ikke får sendt DD/DTS signal fra pc til receiver (via SPDIF), når jeg høyreklikker på lyd ikonet i høyre hjørne på oppgavelinjen og velger egenskaper på "Realtek digital output", og deretter tester DTS/DD får jeg bare et lite knepp i receiveren, men ingen lyd..

    Men problemet kan ikke være receiveren da den tar i mot både Stereo over samme SPDIF kabel, og den tar i mot DD/DTS fra DVD spilleren over en annen SPDIF kabel.

    Er det noen som kan ha noen tips til hva som er galt?
    Sjekk lydkortdriver og innstillinger for den. Må også være satt til spdif for å fungere. Evnt. installere ny Realtek driver.

  3. #3
    Newcomer
    Medlem siden
    Dec 2008
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hadde ett lignende problem selv da jeg innstallerte Vista for et halvt år siden eller så.
    Fikk lyd av recieveren uansett hva jeg spilte, men denville ikke skifte til DD/DTS når jeg spilte av en kilde som hadde DD/DTS-kodet lyd. Ble istede bare PCM, og med det ingen surroundlyd.
    Hos meg viste det seg å være noen innstillinger på lydkortet, sammen med at programmet jeg brukte for dekoding av lyd gjorde akkurat hva det skulle, nemmelig å dekode lyden.
    Da jeg fikk satt ffdshow sin aduio decoder til å bruke passthrough så ble det noe helt annet.
    Men testene i Vista funket hos meg da..

  4. #4
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    har installert nye realtek-drivere uten forandring. Jeg bruker ffdshow og de er satt til use spdif when ac3 passthrough.

    Problemet må være et grunnleggende sted tror jeg, siden jeg ikke får dts og dd lyd gjennom testene til vista.

    Jeg har også prøvd å sette inn et nytt lydkort med optisk spdif utgang, men dessverre utgjorde ikke dette noen forskjell. Vista's tester ville fortsatt ikke sende ac3 over spif, det eneste som skjer når jeg trykker "test" er at det kommer et lite støysignal som varer under et sekund ("pschht" før det blir stille og jeg får spørsmålet "hørte du noen lyd fra dekoderen".

    Jeg har et håp om at det er noe grunnleggende feil på audio-controllerene på hovedkortet slik at et nytt hovedkort vil løse problemet, men derimot burde kanskje det nye lydkortet mitt ha løst dette problemet? Eller kan hovedkortet fortsatt være problemet?

    Jeg har også tidligere innstallert windows xp, med fortsatt samme problem.

    Blir gal av det her..

  5. #5
    Newcomer
    Medlem siden
    Sep 2007
    Poster
    266
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Det du beskriver hadde jeg problemer med selv,og jeg vil tro problemet ligger i codecene. Prøv f.eks kmplayer eller en annen mediaspiller der du kan manuelt konfigurere codec. Velg at den skal sende lyd gjennom Spdif, og gå så inn i hvert enkelt DD/DTS codec og velg det samme der. Det fungerte for meg vertfall.

  6. #6
    Active
    Medlem siden
    Mar 2008
    Poster
    475
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hvilket hovedkort er det du har? Bruker selv bare asus kort med realtek lyd i vista64 ultimate. Har kun ac3filter og coreavc innstallert. Filmer og musikk blir kjørt gjennom wmp11 og powerdvd.

    I ac3filter så har jeg output format satt til "AS IS" pcm 32bit, use SPDIF. På spdif passthrough så har jeg huket av alle 3 (ac3, dts, mpeg). Spdif/dts mode er satt til auto. Spdif/dts conversion er satt til Do not convert.

    Har satt dette oppsettet på mange maskiner, alle med asus kort og ingen problem med lyden på noen av dem.

  7. #7
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    jeg har Asus P5LD2 hovedkort, med optisk spdif utgang.
    Bruker windows vista ultimate x64 og ffdshow, men har også testet ac3 filter.

    som avspiller bruker jeg VLC, men når jeg velger "audio device": A/52 over S/PDIF får jeg opp kun "mute" merket (se bilde).

  8. #8
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hva er det minste jeg trenger for å få "test-tonen" til å sende dts/dd til receiveren?
    Nå har jeg avinstallert alt jeg kan tenke meg (ffdshow også) utenom realtekdriveren..
    fortsatt samme problem.

    Da hjelper det vel ikke å installere ac3 filter tro?

  9. #9
    Newcomer
    Medlem siden
    Dec 2008
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av nonames
    Hva er det minste jeg trenger for å få "test-tonen" til å sende dts/dd til receiveren?
    Nå har jeg avinstallert alt jeg kan tenke meg (ffdshow også) utenom realtekdriveren..
    fortsatt samme problem.

    Da hjelper det vel ikke å installere ac3 filter tro?
    Prøvde å kjøre testtonene her hos meg nå, og fikk det samme støysignalet/klikket i høytalerene imens recieveren skiftet til DTS mode, den spilte så gjennom all testtonene.

    Men hva skjer egentlig når du spiller av ett videoklipp som har DD/DTS lyd? Blir det bare det samme "klikket" i recieveren, også får du ikke lyd i det heletatt, eller blir den avspilt som PCM?

  10. #10
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Heisann, takk for at dere forsøker å hjelpe meg

    Det jeg mener med "klikk" er ikke det vanlige klikket som oppstår når receiveren switcher til 5.1 lydspor slik som den gjør når den oppdager et flerkanal-lydspor.

    Det er mer som et digitalt støysignal som sendes analogt. Og deretter blir det tyst som i graven..

    Men jeg har nå fått kloa i et nytt hovedkort som jeg skal teste ut, og i den forbindelsen reinstallerer jeg alt.

    Så det jeg dermed lurer på nå, for å utelukke flest mulig problemer; hva er minstekravet for å få sendt dts/dd signalet over spdif på et nytt system? Dvs trenger jeg installere ac3filter, ffdshow eller noen codecer får å få det til eller går det på en "ren" installering med de rette realtek driverinstillingene?

  11. #11
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Jovis
    Men hva skjer egentlig når du spiller av ett videoklipp som har DD/DTS lyd? Blir det bare det samme "klikket" i recieveren, også får du ikke lyd i det heletatt, eller blir den avspilt som PCM?
    Hvis instillingene står slik jeg tror er korrekt, med spdif passthrough ac3 så kommer det ingen som helst lyd, slik at jeg hvis jeg skal se på film må jeg forandre lydinstillingene i VLC fra A/52 over S/PDIF til Stereo, og da sender den vanlig tokanals PCM til receiveren. Den bare nekter å sende DD/DTS tydligvis.

  12. #12
    Newcomer
    Medlem siden
    Feb 2007
    Poster
    86
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Du er sikker på at du har valgt spdif ut i programvaren for lydkortet. Dette gjøres under Digital settingen som kan være litt vanskelig å finne. Du har også der muligheten for å teste om lyden går ut som den skal.
    Vedlegg 42067

  13. #13
    Newcomer
    Medlem siden
    Dec 2008
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av nonames
    Hvis instillingene står slik jeg tror er korrekt, med spdif passthrough ac3 så kommer det ingen som helst lyd, slik at jeg hvis jeg skal se på film må jeg forandre lydinstillingene i VLC fra A/52 over S/PDIF til Stereo, og da sender den vanlig tokanals PCM til receiveren. Den bare nekter å sende DD/DTS tydligvis.
    Om du bruker VLC så vil vel innstillinger i ffdshow ha akkurat ingenting å si. VLC er vel selvforsynt med halvgode codecer slik at den funker greit om du bare skal ha noe å spille av med. Vil akkurat der sterkt anbefale å bruke en directshow-spiller som utnytter ffdshow (f.eks. Media Player Classic).

    Ellers, for å få spilt av DD/DTS (testtonene som er i Vista ihvertfall) er vel det eneste kravet at lydkortet er innstallert. Skal faktisk ikke trenge drivere til lydkortet i det heletatt for å bruke optisk/coax-utgangen på hovedkortet, da Vista bare vil sende lyden tvers gjennom, ubehandlet om den ikke har drivere.
    Funket ihvertfall slik på min Abit IX38 med Realtek ALC888.

  14. #14
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Problemet er løst, men..

    Jepp, da fant jeg ut hva problemet var.. det viser seg at receiveren min ikke vil motta dts/dd signalene fra pc over den OPTISKE spdif kabelen, men derimot fungerer det fint over COAX kabelen.. merkelig. Den tar jo i mot stereo over den optiske kabelen så.. kanskje den ikke klarer sende DD/DTS signaler over en viss lengde? (jeg har 3 meter lang kabel).

    Men, da starter jeg på scratch med ny installasjon.

    Hva er anbefalt programvare jeg bør bruke i mitt HTPC?
    * FFdshow og media player classic?

    hvilke codecs bør jeg bruke?

  15. #15
    Newcomer
    Medlem siden
    Dec 2008
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av nonames
    Jepp, da fant jeg ut hva problemet var.. det viser seg at receiveren min ikke vil motta dts/dd signalene fra pc over den OPTISKE spdif kabelen, men derimot fungerer det fint over COAX kabelen.. merkelig. Den tar jo i mot stereo over den optiske kabelen så.. kanskje den ikke klarer sende DD/DTS signaler over en viss lengde? (jeg har 3 meter lang kabel).

    Men, da starter jeg på scratch med ny installasjon.

    Hva er anbefalt programvare jeg bør bruke i mitt HTPC?
    * FFdshow og media player classic?

    hvilke codecs bør jeg bruke?
    Merkelig det der, bruker selv en 5m optisk kabel fra Clas Ohlson uten noe problem.
    Av programvare, ffdshow tar det meste av formater, sammen med Haali Mediasplitter for avspilling av MKV-filer.
    Meida Player Classic HC gir god kvalitet, kjører lett og er enkel å bruke. Bare deaktiver alle codecene som er innlagt slik at den bruker ffdshow for all avspilling.

    Edit: Alternativt kan du bruke CCCP. Noe så uvanlig som en god codec-pakke. Inneholder ffdshow, Haali, MPC og litt annet småsnacks som gir best mulig avspilling av de aller fleste formater.

  16. #16
    Newcomer
    Medlem siden
    Feb 2008
    Poster
    51
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Dropp VLC! Deres decoder suger hardt! Nyeste ac3filter i mpc er tingen. Verifiser at ac3filter brukes i mpc og ingenting annet. Noen ganger blander ffdshow seg inn. Blokker da ffdshow audio decoder i mpc->options->external filters. Sett "prefer" samme plass for ac3filter.

  17. #17
    Newcomer
    Medlem siden
    Feb 2008
    Poster
    51
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av nonames

    hvilke codecs bør jeg bruke?
    Det som er geniale med ac3filter er at det kan brukes som passthrogh, dvs at receiveren din decoder Det ganske sikkert det beste i og med at Yamaha hersker:twisted:

  18. #18
    Newcomer
    Medlem siden
    Dec 2008
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av pspeters
    Det som er geniale med ac3filter er at det kan brukes som passthrogh, dvs at receiveren din decoder Det ganske sikkert det beste i og med at Yamaha hersker:twisted:
    Dette gjør ffdshow også, så slipper du å bruke flere programmer enn nødvendig.
    (ja, jeg bruker det selv og det fungerer utmerket)

  19. #19
    Newcomer
    Medlem siden
    Mar 2006
    Poster
    63
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Da ble det community codec pack eller hva det het med ffdshow og mpc.

    Fungerer utmerket med dd og dts nå. Med ny tv (pioneer lx5090) over hdmi er også bildet blitt bra.

    Forsøkte også oppskalere dvd filmer med ffdshow, men ser ut til at min pentium d930 kom til kort for denne oppgaven.. kan det stemme tro? Eller har jeg gjort noe galt?

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •