Linux MCE, bare hype eller fungerer det? - Side 2

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 2 av 2 FørsteFørste 1 2
Viser resultater 21 til 35 av 35
  1. #21
    Newcomer
    Medlem siden
    Jan 2009
    Poster
    24
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Multiproto er ute. Det er bare S2API som gjelder nå. Om du bruker hg repository til s2-liplianin eller Mercurial repositories index går ut pa det samme da de begge støtter fullt ut s2api protokollen nå. Dette betyr at compiler.h er har blitt oppdatert med støtte for dvb api 5. Den compiler.h som ligger i din kernel-source har bare støtte for den eldre dvb api.
    Har du husket å linke den oppdaterte compiler.h som ligger i s2-liplianin eller i dvb source
    cd /usr/local/src/s2-liplianin/linux/include/linux/
    ln -s /usr/src/kernels/`uname -r`/include/linux/compiler.h

    Jeg ser at ticket 10 som er for S2API support har de allerede lagt inn i revisjon 65 i opensascng source
    https://opensvn.csie.org/traccgi/opensascng/ticket/10
    Du skulle ikke ha hatt problemer med å kompilere med s2api dvb source da. Du skulle ikke trenge s2api patch, heller ikke den manuelle måten jeg dokumenterte i min wiki. Jeg har ikke kompilert denne revisjon selv men hvis du vil kan jeg prøve det imorgen for å se om jeg får problemer

    Det beste av dokumentasjonen man finner på Internett er ikke oppdatert hvordan man skal handtere skiftet til den nye dvb api 5 protokollen. Men her er noe.
    Getting Pay TV to Work With MythTV: Open Media Centre
    https://opensvn.csie.org/traccgi/opensascng/wiki
    #5882 (S2API support) – MythTV – Trac

    Det ma ikke gi opp. Jeg brukte uhorvelig mye tid på dette, men til gjengjeld har jeg lært mye underveis.

  2. #22
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Takk for gode svar. Jeg har nettop startet med Linux, og som du selv sier, har lært my underveis...

    Et av problemene mine er at jeg ikke har den grunnleggende forståelsen av hvordan Linux virker med tanke på kompilering. Er det slik at når man laster ned kilde og kjører make, så forberedes mappen og bygges moduler slik at disse kan legges inn i kjernen ved "make install"?

    Hva skjer om man kjører make install på en kode som ikke er kompilert riktig. Kan man gå tilbake på dette etter en reboot?

    Det du skriver i posten din om ticket 10 i rev 65; betyr det at dersom jeg kompilerer s2-liplianin dvd-driverne og installerer rev 65 over dette, vil jeg kunne få støtte for HD-kanaler og open-sasc-ng?

  3. #23
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Et spørsmål til denne:
    For å oppnå denne støtten som er beskrevet i Ticket 5882, må man da kjøre alle patcher som ligger under atachments, og i hvilken mappe må de i så fall kjøres fra.

    Beklager noob-spørsmål, men jeg greier ikke helt å legge dette fra meg. Blir litt oppslukt av linux-mystikken....

  4. #24
    Active
    Medlem siden
    Aug 2007
    Poster
    499
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wOOFer
    Et spørsmål til denne:
    For å oppnå denne støtten som er beskrevet i Ticket 5882, må man da kjøre alle patcher som ligger under atachments, og i hvilken mappe må de i så fall kjøres fra.

    Beklager noob-spørsmål, men jeg greier ikke helt å legge dette fra meg. Blir litt oppslukt av linux-mystikken....
    I denne posten http://avforum.no/forum/htpc-softwar...ml#post1091604 har jeg listet de patchene jeg bruker for å få inn DVB-S2. Jeg regner med at du bruker trunk, og derfor har en katalog som heter trunk som rot for kildekoden.
    Gjør:
    Kode:
    cd trunk/mythtv
    patch -p 0 < t5882_S2Api_5.diff (Denne feiler på en fil (dvbtypes.h tror jeg) på nyere versjoner av trunk. Hvis du sammenligner dvbtypes.h.rej og dvbtypes.h.orig skulle det være lett å rette dette manuelt.)
    cd libs
    patch .p 0 < bad_tuning_fix.diff
    patch .p 0 < vdr_conf.diff
    patch .p 0 < inappropriate_mux.diff
    patch .p 0 < channel_mux_patch2.diff
    Changeset 19094 er allerede med i nyere versjoner av trunk.

  5. #25
    Active
    Medlem siden
    Aug 2007
    Poster
    499
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wOOFer
    Har nå fulgt følgende howto (http://rigolo.googlepages.com/sasc-ng)til punkt og prikke, og alt går fint intil jeg kjører open-sacs-ng med følgende kommando "./sasc-ng -j 0:1 "

    Jeg får da følgende feilmelding:

    Feb 4 21:08:42.280 frontend: Could not open /dev/dvb/adapter1/frontend1. Error was: 16
    Open failed
    : Device or resource busy

    Hva kan dette skyldes?

    Jeg kjører MythBuntu 8.10 med FTA-kanaler igang på MythTV...
    v4l-dvb har nyere versjoner av en del DVB relaterte filer enn det sasc-ng har.
    Hvis du kopierer dvbdev.h fra v4l-dvb til sasc-ng før du kompilerer så skal det fungere.

    Der er en sticky for sasc-ng på DVBN linux forumet. Har du sjekket den?

  6. #26
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har nå fulgt guiden på Dolot for å installere S2-api (liplianin). Alt går bra helt frem til siste modprobe. Får da fatal error!

    root@Ubuntu-HTPC:/usr/local/src/s2-liplianin# modprobe budget-ci
    FATAL: Error inserting budget_ci (/lib/modules/2.6.27-7-generic/kernel/drivers/media/dvb/ttpci/budget-ci.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    dmesg gir følgende:
    [ 112.848277] ppdev0: registered pardevice
    [ 112.896197] ppdev0: unregistered pardevice
    [ 112.909935] ppdev0: registered pardevice
    [ 112.956053] ppdev0: unregistered pardevice
    [ 114.623024] ppdev0: registered pardevice
    [ 114.668115] ppdev0: unregistered pardevice
    [ 1333.043793] budget_ci: Unknown symbol ir_codes_tt_3200
    [ 1333.043911] budget_ci: disagrees about version of symbol ir_input_init
    [ 1333.043913] budget_ci: Unknown symbol ir_input_init
    [ 1333.044186] budget_ci: disagrees about version of symbol ir_input_nokey
    [ 1333.044188] budget_ci: Unknown symbol ir_input_nokey
    [ 1333.048100] budget_ci: disagrees about version of symbol ir_input_keydown
    [ 1333.048105] budget_ci: Unknown symbol ir_input_keydown
    [ 1381.030110] budget_ci: Unknown symbol ir_codes_tt_3200
    [ 1381.030230] budget_ci: disagrees about version of symbol ir_input_init
    [ 1381.030232] budget_ci: Unknown symbol ir_input_init
    [ 1381.030507] budget_ci: disagrees about version of symbol ir_input_nokey
    [ 1381.030509] budget_ci: Unknown symbol ir_input_nokey
    [ 1381.031675] budget_ci: disagrees about version of symbol ir_input_keydown
    [ 1381.031681] budget_ci: Unknown symbol ir_input_keydown

    Kan dette skyldes at S2-api ikke kommuniserer med Hauppauge Nova-kortet. Jeg har ikke rebootet etter make install?

    Etter reboot greide jeg å modprobe samtlige moduler...

  7. #27
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Når jeg så følger guiden på Dolot for å installere open-sasc-ng skjer følgende når jeg patcher for s2-api:

    root@Ubuntu-HTPC:/usr/local/src/opensasc# patch -p0 < opnsascng.20081104.patch
    patching file dvbloopback/module/dvb_loopback.c
    Hunk #1 FAILED at 50.
    Hunk #2 FAILED at 122.
    Hunk #3 FAILED at 150.
    Hunk #4 FAILED at 182.
    Hunk #5 FAILED at 239.
    Hunk #6 FAILED at 303.
    Hunk #7 succeeded at 543 (offset 23 lines).
    Hunk #8 FAILED at 602.
    Hunk #9 FAILED at 638.
    Hunk #10 FAILED at 697.
    Hunk #11 FAILED at 783.
    Hunk #12 FAILED at 1036.
    11 out of 12 hunks FAILED -- saving rejects to file dvbloopback/module/dvb_loopback.c.rej
    patching file dvbloopback/src/plugin_getsid.c
    Hunk #1 FAILED at 761.
    1 out of 1 hunk FAILED -- saving rejects to file dvbloopback/src/plugin_getsid.c.rej

    Hva er det som skjer her? Har dette noe med skriverettigheter å gjøre. Jeg kjører jo root... Forstår ikke hvorfor patchen feiler. Noen tips???

  8. #28
    Active
    Medlem siden
    Aug 2007
    Poster
    499
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wOOFer
    Har nå fulgt guiden på Dolot for å installere S2-api (liplianin). Alt går bra helt frem til siste modprobe. Får da fatal error!

    root@Ubuntu-HTPC:/usr/local/src/s2-liplianin# modprobe budget-ci
    FATAL: Error inserting budget_ci (/lib/modules/2.6.27-7-generic/kernel/drivers/media/dvb/ttpci/budget-ci.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    dmesg gir følgende:
    [ 112.848277] ppdev0: registered pardevice
    [ 112.896197] ppdev0: unregistered pardevice
    [ 112.909935] ppdev0: registered pardevice
    [ 112.956053] ppdev0: unregistered pardevice
    [ 114.623024] ppdev0: registered pardevice
    [ 114.668115] ppdev0: unregistered pardevice
    [ 1333.043793] budget_ci: Unknown symbol ir_codes_tt_3200
    [ 1333.043911] budget_ci: disagrees about version of symbol ir_input_init
    [ 1333.043913] budget_ci: Unknown symbol ir_input_init
    [ 1333.044186] budget_ci: disagrees about version of symbol ir_input_nokey
    [ 1333.044188] budget_ci: Unknown symbol ir_input_nokey
    [ 1333.048100] budget_ci: disagrees about version of symbol ir_input_keydown
    [ 1333.048105] budget_ci: Unknown symbol ir_input_keydown
    [ 1381.030110] budget_ci: Unknown symbol ir_codes_tt_3200
    [ 1381.030230] budget_ci: disagrees about version of symbol ir_input_init
    [ 1381.030232] budget_ci: Unknown symbol ir_input_init
    [ 1381.030507] budget_ci: disagrees about version of symbol ir_input_nokey
    [ 1381.030509] budget_ci: Unknown symbol ir_input_nokey
    [ 1381.031675] budget_ci: disagrees about version of symbol ir_input_keydown
    [ 1381.031681] budget_ci: Unknown symbol ir_input_keydown

    Kan dette skyldes at S2-api ikke kommuniserer med Hauppauge Nova-kortet. Jeg har ikke rebootet etter make install?

    Etter reboot greide jeg å modprobe samtlige moduler...
    Er det denne du har fulgt? Install S2API - Dolot

    Den sier ingenting om hva slags kort dette gjelder. Du skal bruke andre kjernemoduler enn det som er nevnt der.

    Foreslår at du tar en titt her: Hauppauge WinTV-NOVA-HD-S2 - LinuxTVWiki
    Det er litt mere detaljer her: Hauppauge WinTV-HVR-4000 - LinuxTVWiki WinTV-NOVA-HD-S2 er en WinTV-HVR-4000 uten analoge innganger.

  9. #29
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Strålende. Dette forklarer jo noe... Skal teste i kveld etter jobb.

    Tror du at dette er grunnen til at patchen på open-sasc-ng feiler?

  10. #30
    Active
    Medlem siden
    Aug 2007
    Poster
    499
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wOOFer
    Strålende. Dette forklarer jo noe... Skal teste i kveld etter jobb.

    Tror du at dette er grunnen til at patchen på open-sasc-ng feiler?
    Hvilken versjon av open-sasc-ng bruker du?

    Jeg tror du kan kjøre svn info i open-sasc-ng katalogen for å se det.

    Dersom du har en versjon som er nyere enn fra 7. februar så er denne patchen allerede inkludert.

  11. #31
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av jpterj
    Hvilken versjon av open-sasc-ng bruker du?

    Jeg tror du kan kjøre svn info i open-sasc-ng katalogen for å se det.

    Dersom du har en versjon som er nyere enn fra 7. februar så er denne patchen allerede inkludert.
    Siste versjon, 67 tror jeg. Nå har jeg forsøkt flere forskjellige guider for å installere open-sasc-ng. Har fulgt denne, uten susksess:
    https://opensvn.csie.org/traccgi/ope...buntudvbcguide

    Og denne:
    Install SASC-NG - Dolot

    Ser ut som om det feiler under make. Får en error, og kompileringen tar kun 2 sek. Det skapes heller ikke noen sasc-ng-mappe som det senere vises til...

    Er det noen som gidder å lage/referere til en step-by-step for open-sasc-ng under MythBuntu 8.10 eller Ubuntu 8.10 med siste v4l-dvb drivere og Hauppauge Nova S2 for en arme noob??

  12. #32
    Newcomer wOOFer sin avatar
    Medlem siden
    Apr 2006
    Poster
    26
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Endelig kjører open-sasc-ng mot min dreambox. Takk til alle tålmodige sjeler. Det var følgende prosedyre som ga resultater:
    rigolo - MythBuntu 8.10 and open-sasc-ng

    Måtte kjøre patchene manuelt...

    Nå mangler jeg bare å laste moduler og sasc-ng ved boot. Noen tips for hvordan jeg kan gjøre det?

  13. #33
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av wOOFer
    Endelig kjører open-sasc-ng mot min dreambox. Takk til alle tålmodige sjeler. Det var følgende prosedyre som ga resultater:
    rigolo - MythBuntu 8.10 and open-sasc-ng

    Måtte kjøre patchene manuelt...

    Nå mangler jeg bare å laste moduler og sasc-ng ved boot. Noen tips for hvordan jeg kan gjøre det?
    Jeg har igjen å mekke init script, så jeg gjør det slik inntill videre:
    Det er litt teit, plukk ut det du trenger..

    Kode:
    #!/bin/bash
    sudo echo "Skriv inn passord"
    sudo pkill -9 sasc-ng*
    cd ~/new_sasc/opensascng/open-sasc-ng
    sudo /etc/init.d/mythtv-backend stop
    sudo insmod ~/new_sasc/opensascng/open-sasc-ng/dvbloopback.ko num_adapters=2
    sudo sleep 3
    sudo ./sasc-ng -j 0:2 -j 1:3 -d 0xf0a --cam-budget &
    sudo sleep 4
    sudo /etc/init.d/mythtv-backend start
    mythfrontend
    Jeg oppgradere til siste open-sasc-ng i helga og trengte ikke patche den lenger hvis jeg la inn følgende.

    Kode:
    sudo apt-get install g++-4.2
    Så kjørte jeg inn med
    Kode:
    ./configure --cxx=/usr/bin/g++-4.2
    først.

  14. #34
    Newcomer
    Medlem siden
    May 2008
    Poster
    14
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Krever revisjon 68 av Opensasc 2.6.28 og høyrere ved bruk av s2liplianin?

    får en haug med declation feilmelding under kompilering av kjernen. (har kompliert s2 som modul under 2.6.27-11-generic )

    ./configure --shared --dvb-dir=/usr/src/s2-liplianin/linux --cxx=/usr/bin/g++-4.2 (ubuntu)

    eks feilm.
    error: conflicting declaration «typedef __blkcnt_t blkcnt_t»

  15. #35
    Newcomer
    Medlem siden
    May 2008
    Poster
    14
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Ja, ser sånn ut. Funker bra nå med Jaunty 2.6.28-9-generic

Side 2 av 2 FørsteFørste 1 2

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •