Ikke DTS 5,1 lyd på MKV filer

Sponsorer:
Takk Takk:  0
Like Like:  0
Viser resultater 1 til 16 av 16
  1. #1
    Newcomer
    Medlem siden
    Nov 2007
    Poster
    14
    Takk & like
    Nevnt
    1 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Ikke DTS 5,1 lyd på MKV filer

    Jeg har Vista Ultimate og har installert K-Lite Mega Codec Pack 3.9.0.
    Free-Codecs.com :: Download K-Lite Mega Codec Pack 3.9.0 : The K-Lite Mega Codec Pack includes the K-Lite Codec Pack Full, QuickTime Alternative, Real Alternative support and Monkey's Audio DirectShow decoder.

    Jeg kjører lyd og bilde over HDMI på min Shuttle pc med "7.1 channel High Definition Audio, Realtek ALC888DD codec" på ett "Intel G33 Express" chipsett.

    Når jeg spiller DVD filmer får jeg DTS, multichannel eller HDMI passthrough. Det er en fryd å høre på.

    Jeg har noen filmer i MKV som skal ha 5.1 eller DTS, men her får jeg ikke noe mer enn stereo (hvis jeg er så heldig).

    Er det noen som vet hva jeg stille inn/gjøre for å få skikkelig lyd?

  2. #2
    Newcomer xoop sin avatar
    Medlem siden
    Nov 2004
    Poster
    231
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har du vært inne og konfigurert AC3 filteret?
    Her må du velge hva slags lyd ut du ønsker...

  3. #3
    Newcomer
    Medlem siden
    Nov 2007
    Poster
    14
    Takk & like
    Nevnt
    1 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg har satt den til 5.1, men det kan være mulig jeg gjør noe feil ja.

    Du har ikke mulighet til å guide meg?

  4. #4
    Newcomer xoop sin avatar
    Medlem siden
    Nov 2004
    Poster
    231
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Legg en "screendump" av oppsettet ditt her så er det litt enklere å se på de innstillingene du har.

  5. #5
    Newcomer
    Medlem siden
    Nov 2007
    Poster
    14
    Takk & like
    Nevnt
    1 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Det kan jeg ikke nå, men senere i dag.
    Det er uansett default oppsett.

  6. #6
    Newcomer
    Medlem siden
    Apr 2008
    Poster
    49
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg hadde samme problem med VLC player og spdif, men du bruker ikke den?
    Jeg løste problemet med å bruke zoom player

  7. #7
    Intermediate
    Medlem siden
    May 2004
    Poster
    732
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    husk at det er mange MKV filer med bare AC3 stereo lyd.

  8. #8
    Newcomer
    Medlem siden
    Feb 2008
    Poster
    71
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Ikke rote sammen begreper.

    .mkv er en container, som kan inneholde video, lyd, tekst. Den er mer avansert og bedre enn .avi, da man kan ha en drøss tekster, flere lydspor, oppdelt video med forskjellige spor (som på en DVD) mm.

    h264 er en codec som ofte brukes i .mkv-containere.

    Hvis man vil legge til tekst, lyd, video osv selv inn i en .mkv, er mkvtoolnix uunnværlig.

    Unngå codec packs. Man mister oversikt og alt blir bare rot. Det du trenger for å spille alt mulig er:

    media player classic
    CoreAVC
    AC3filter
    Haali media splitter
    Koepi Xvid
    directvobsub
    +mpeg2-kodek av eget valg.

    I media player classic kan du gå inn i options og konfigurere hvilke filtre som skal brukes manuelt, slik at du unngår konflikter. Husk å disable media player classics interne audio splitter. Sett passthrough i AC3filter.

    Hvis du lurer på hva som er inni .mkv'en du skal spille, trykk på F10 mens du spiller filen. Kommer opp info om video og lydspor.

    På "pirat"-x264'er er det vanligst med AC3, fordi scene-gruppene som regel ekstraherer DD ut av DD+ sporet på Blu-Ray'en. Vil du ha DTS, kan du ta lyden fra en NTSC DVD av samme film og muxe inn i .mkv'en med mkvtoolnix.

  9. #9
    Active teoh sin avatar
    Medlem siden
    Dec 2004
    Poster
    328
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av samuel
    Jeg har satt den til 5.1, men det kan være mulig jeg gjør noe feil ja.

    Du har ikke mulighet til å guide meg?
    Skal settes til passthrough

  10. #10
    Intermediate Okay sin avatar
    Medlem siden
    Oct 2006
    Poster
    1,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    ALLE bør lese godt gjennom dtddvier sin post, da det her rotes MYE.

    Av codecer etc. er et enda enkere valg FFDShow + Haali, som dekker det meste. CoreAVC koster peng - men mange mener det er verd det. Selv bruker jeg Cyberlink for å utnytte DXVA. Et gratisalternative er AVIVO - om du har ATi x-serie eller bedre ...

  11. #11
    Newcomer
    Medlem siden
    May 2005
    Poster
    32
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Mulig jeg er blind, men eneste stedet jeg finner passthrough er i forbindelse med SPDIF. Har ac3 versjon 1.46
    Har prøvd å få til 5.1 og dts et par dager nå med nyinnkjøpt acer L5100 via hdmi, men ikke fått det til. Ble også mye småhakking i bildet. Gikk over til vga+optisk så var problemet løst med både lyd og bilde.

  12. #12
    Newcomer
    Medlem siden
    Feb 2008
    Poster
    71
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av THX
    Mulig jeg er blind, men eneste stedet jeg finner passthrough er i forbindelse med SPDIF. Har ac3 versjon 1.46
    Har prøvd å få til 5.1 og dts et par dager nå med nyinnkjøpt acer L5100 via hdmi, men ikke fått det til. Ble også mye småhakking i bildet. Gikk over til vga+optisk så var problemet løst med både lyd og bilde.
    Les posten min igjen. Du MÅ disable MPCs interne lydsplitter.

  13. #13
    Newcomer rp1983 sin avatar
    Medlem siden
    May 2008
    Poster
    42
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hadde samme problem som trådstarter. Brukte HDMI kabel fra et Gigabyte hovedkort med HDMI utgang, direkte inn i min reciver, også til prosjektor. Brikkesettet og grafikk løsningen er fra AMD/ATI ( radeon 3200 integrert grafikk) Stereo lyd fungerte nesten alltid via HDMI, men 5,1 lyd var et ******* å få til. Da både fra DVD og MKV filer.
    Har prøvd allt av codecer og filter. Og det kunne fungere ene dagen, men ikke den neste. Så HDMI på PC anbefaler jeg overhode ikke til lydoverføring, hvis du vil ha annet en stereo lyd. Til bilde fungerer det utrolig bra.
    Så løsningen min ble Coreavc og AC3 filter. HDMI kabel rett i prosjektor. SPDIF kabel fra pc til reciver. Og nå fungerer det kjempebra. Så mitt råd, dropp den satans HDMI-en, den fører kun til masse irritasjon og plager, bruk optisk kabel istedefor.

  14. #14
    Newcomer
    Medlem siden
    May 2005
    Poster
    32
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av dtddiver
    Les posten min igjen. Du MÅ disable MPCs interne lydsplitter.
    Den er disablet. Kan se på ac3 under avspilling av mkv filer og der er det full fart i grafene både på input og output (indikerer lyd i alle kanaler), men ingen 5.1 lyd i høyttalerene. Spiller fortsatt i pro logic.

  15. #15
    Intermediate Spareblære sin avatar
    Medlem siden
    Mar 2008
    Poster
    1,060
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har du fått orden på lyden?
    Jeg hadde det samme problemet, løsningen var å endre innstillinger under codecs i ffdshow audio decoder. Standardinnstillingen er Liba52 for AC3 og LibDTS for DTS. Jeg endret disse til S/PDIF, og da virket det.

  16. #16
    Active
    Medlem siden
    Apr 2006
    Poster
    404
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har store problemer med å høre DTS på mkv filer(med dts).

    Kjører optisk spdif fra htpc'en. Bruker mpc classic.

    Har gått inn og slått av det interne filteret. Men fremdeles ingen dts.
    Går inn i AC3 konfigurasjonen, og huker av "use SPDIF". Men fremdeles ingen dts. På "output" rett ovenfor sto det "stereo", her kan man velge mange forskjellige oppsett, 1/0 Mono, 1/2 stereo, 2/1 surround, osv osv.
    Når jeg huker av "3/2+sw 5.1 channel" så får jeg Dolby Digital på Pioneer receiveren. Men fremdeles blir ikke dts detektert.

    Noen som har noen tips?

    Edit: vært å rotet inne i AC3 filteret og fikk til slutt DTS frem på displayet på receiveren. Vil det da si at jeg har greid det, eller kan det være at jeg har greid å sende stereolyd som Dts?

    Inne i AC3 filter egenskapene, forandret jeg dette:

    Under Main fanen, Output -> fra "2.1 stereo" til "AS IS (no change)", og huket av SPDIF, samt står på PCM16bit.
    Under system fanen: "Use AC3 filter for": huket av AC3, DTS, PES(DVD), ikke PCM og mpeg audio.
    SPDIF passthrough: Her var kun AC3 huket av, så jeg huket av DTS også, mpeg audio ikke avhuket. Var det dette som gjorde det store, er det riktig gjort?

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •