Dårlig bildekvalitet ved avspilling av h264

Sponsorer:
Takk Takk:  0
Like Like:  0
Viser resultater 1 til 6 av 6
  1. #1
    Newcomer jcberg sin avatar
    Medlem siden
    Sep 2007
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Dårlig bildekvalitet ved avspilling av h264

    Har veldig dårlig bildekvalitet ved avspilling av h264 fra min PC inn på TV'n. Spiller video i 720p oppløsning med helt normal bitrate. Bruker ffmpeg som video-kodek, og har prøvd både med og uten postprosessering (fungerer bedre uten).


    Problemene er at skygger og mørke områder ikke er fine, jevne og mørke, de er grå-grønnaktige og har veldig ujevne overganger til forskjellige grå-grønntoner.

    Stillestående objekter/flater som vegger etc. virker "urolige" og har også veldig markante fargeskiller og "haloer".

    Panoreringer er ganske hakkete.



    Kan dette være et maskinvare-problem, eller er det mest sannsynlig noe i software? Ser samme tendensene med Divx/Xvid også, der ensfargede flater som vegger osv. har "flekker" med en mørkere / lysere nyanse osv og det samme problemet med grønnaktige skygger og fargeskiller bare i litt mindre grad.


    Ellers er bildekvaliteten på h264 utrolig bra (veldig skarpt) så lenge det ikke er skygger og ensfargede flater o.l. i scenen og det ikke er for krevende panoreringer.


    Men enn så lenge foretrekker jeg faktisk DivX/XviD fra min moddede PlayStation 2 ops: Der er ensfargede flater fine og ensfargede, skygger er grå-sorte og har gradvise overganger og problemer med "haloer" og hakkende panoreringer er ikke-ekstisterende. Så får det bare være at bildet er relativt uskarpt.



    Skal nevne at dette ikke er en dedikert HTPC, bruker min Dell Vostro 1500 laptop m. Core2Duo 2ghz, 2gb RAM, nvidia 8600GT. Kanskje ikke kjempespecs, men bør iallefall klare DivX uten postprosessering. Den er tilkoblet TV'n via vanlig VGA kabel, av type "billig". Lurer kanskje på om kabelen kan være synderen, men tviler...


    Skal prøve tilkobling med svideo også og se åssen det går. Bildet er forresten bedre på PCskjermen enn på TV'n.

  2. #2
    Intermediate Okay sin avatar
    Medlem siden
    Oct 2006
    Poster
    1,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Prøv alternativ kodek, eks. Cyberlink PowerDVD.

    FFMPEG er vel ren software dekoder?

  3. #3
    Intermediate Burre sin avatar
    Medlem siden
    Apr 2003
    Poster
    3,071
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Du kan jo prøve avisynth guiden for ffdshow som ligger her på forumet, under artikler...

    Men vær forberedt på noen timers prøving og feiling, om du ikke har en veldig sterk pc...

  4. #4
    Newcomer jcberg sin avatar
    Medlem siden
    Sep 2007
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Ok. Skal se om jeg finner den, ligger den i Generelle artikler?


    Har prøvd med CoreAVC, og det ser ut som om det er blitt bedre, men vanskelig å si da jeg ikke får prøvd på TV'n akkurat nå (kjerringa ser på film)..


    Skal prøve PowerDVD også.

    Kan legge til at jeg bruker Media Player Classic HomeCinema som avspiller. Vil det være bedre å bruke f.eks. Zoom Player? (MPC blir litt rotete med innebygde kodeker og skalering mm)
    Lurer litt på om det er den bikubiske resize-algoritmen til MPC som skaper problemer. Får heller ikke slått av skalering i MPC.

    Prøvde å bruke Lanczos i ffmpeg men da ble det helt ubrukelig.



    Edit: Fant guiden, men har allerede fulgt "fullversjonen" på avsforum.

  5. #5
    Newcomer jcberg sin avatar
    Medlem siden
    Sep 2007
    Poster
    254
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Etter å ha stilt litt på bildeinstillingene (b.l.a. kontrast var stilt abnormt høyt) og byttet til Cyberlink sin kodek ble det mye bedre. Hovedproblemet er nå at jeg har altfor mye falsk "skarphet" i bildet. Aner at dette er et problem med PC'n, men får ikke stilt det bort.

    Feiler totalt på denne testen:
    Sharpness - Lagom LCD test

    Og får ikke stilt det bra. "Skarphet" går ikke å stille på i nvidia-kontrollpanel Men har satt skarphet på 0 i bildeinstillinger på TV'n.



    Eneste som er igjen av feil nå er litt ujevn gråtone i skygger. Får litt streker her:

    Gradient (banding) - Lagom LCD test



    Men alt kan man ikke forvente av 42" plasma til 5000 kroner og lossy kodeker Er veldig bra nå.

  6. #6
    Intermediate Okay sin avatar
    Medlem siden
    Oct 2006
    Poster
    1,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    *glem det*

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •