Får ikke til 5.1 lyd på HTPC

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 1 av 2 1 2 SisteSiste
Viser resultater 1 til 20 av 28
  1. #1
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Får ikke til 5.1 lyd på HTPC

    Hei, jeg har dette barebonet,
    Komplett.no - MSI Media Live, C51PVG/MCP51, Socket-AM2 ,DDR2, VGA, Firewire, SCART, HDMI, GbLAN

    som er klart for High Definition Audio + 7.1 surround.

    Jeg har en reciever som fungere som den skal, sammen med høytalere som står i 5.1. Da jeg kopler den optiske lydkablen i Xbox 360'en, virker 5.1 som den skal, men over i pc'n virker den ikke.

    Det er installert Realtek Audio på maskina som 'driver' for det integrerte lydkortet. Jeg prøver å si fra at jeg har 5.1, men den klarer ikke å få lyd av de to bakre høytalerene, bare de forrerste. Jeg har satt at jeg har 5.1 høytalere også under kontrollpanelet.

    Noen som har noen som helst anelse?

  2. #2
    Active teoh sin avatar
    Medlem siden
    Dec 2004
    Poster
    328
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Lydinnstillinger skal være satt til passthrough i audio software, ikke noe annet. Da skulle det fungere fint.

  3. #3
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jasså? Hvor kan jeg finne dette? Takk.

  4. #4
    Active
    Medlem siden
    Mar 2008
    Poster
    475
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hvilken mediaspiller bruker du og hva slags windows er innstallert?

  5. #5
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg kjører en lydtest i Realtek. Jeg finner ikke noe 'passthrough'. Det er snakk om Windows XP Sp2.

  6. #6
    Active B1aR sin avatar
    Medlem siden
    Sep 2005
    Poster
    490
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    I innstillingsmenyen på mediaavspilleren din setter du SPDIF passthrough for DTS/AC3 lyd.

  7. #7
    Active B1aR sin avatar
    Medlem siden
    Sep 2005
    Poster
    490
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Forrige innlegget mitt krever at du bruker SPDIF, gjør du det? Hvis ikke det heller fungerer må du kanskje bruke "8 x lyd - utgang - RCA" som jeg ser du har.

  8. #8
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hva er SPDIF?

  9. #9
    Active B1aR sin avatar
    Medlem siden
    Sep 2005
    Poster
    490
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av zkowie
    Hva er SPDIF?
    Wikipedia er din venn
    S/PDIF - Wikipedia, the free encyclopedia

  10. #10
    Intermediate amazon1969 sin avatar
    Medlem siden
    May 2007
    Poster
    569
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    har du installert AC3 Filter? Om du ikke har det bør du gjøre det. Eventuelt laste ned K-lite Mega Codec Pack. Den har AC3 Filter og ellers alle andre codec som man trenger.

    Link AC3 Filter: Free-Codecs.com :: Download AC3 Filter 1.46 : AC3 Filter is a DirectShow filter for AC3 decoding

    Link K-lite: Free-Codecs.com :: Download K-Lite Mega Codec Pack 3.8.0 : The K-Lite Mega Codec Pack includes the K-Lite Codec Pack Full, QuickTime Alternative, Real Alternative support and Monkey's Audio DirectShow decoder.

    Når du har installert AC3 Filter går du på:
    Start-> All Programs->AC3 Filter->SPDIF
    Der huker du av "passthrough" på DTS og AC3.

    Vips så sendes signalet urørt som DD AC3 eller DTS til recieveren din via SPDIF (Sony Philips Digital Interface), akkurat slik som DVD spilleren gjør.

  11. #11
    Newcomer Focalmann sin avatar
    Medlem siden
    Dec 2004
    Poster
    133
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Question

    Sitat Opprinnelig postet av amazon1969
    har du installert AC3 Filter? Om du ikke har det bør du gjøre det. Eventuelt laste ned K-lite Mega Codec Pack. Den har AC3 Filter og ellers alle andre codec som man trenger.

    Link AC3 Filter: Free-Codecs.com :: Download AC3 Filter 1.46 : AC3 Filter is a DirectShow filter for AC3 decoding

    Link K-lite: Free-Codecs.com :: Download K-Lite Mega Codec Pack 3.8.0 : The K-Lite Mega Codec Pack includes the K-Lite Codec Pack Full, QuickTime Alternative, Real Alternative support and Monkey's Audio DirectShow decoder.

    Når du har installert AC3 Filter går du på:
    Start-> All Programs->AC3 Filter->SPDIF
    Der huker du av "passthrough" på DTS og AC3.

    Vips så sendes signalet urørt som DD AC3 eller DTS til recieveren din via SPDIF (Sony Philips Digital Interface), akkurat slik som DVD spilleren gjør.

    Aaahh, damn så irriterende! Nå var jeg sikker på at du kom med løsningen, og jeg fant AC3 Filteret med en gang også. Men tror du det hjalp? Har slitt med å få 5,1 lyd ut fra min Asus laptop helt siden jeg kjøpte den i desember ifjor... Flere glupe hoder som har prøvd forskjellige ting, uten at noe hjelper. Det er kun 2 kanals PCM stereo uansett hvilken avspiller jeg bruker,Mediaplayer, Mediaplayer Classic, VLC. Har vært inne på alt av instillinger. Kjører digital MiniToslink 3,5mm ut og rett i en Rxv-1700. Hvis jeg putter i en DVD i skuffen, får jeg 5,1 DD og DTS med en gang..?

  12. #12
    Intermediate amazon1969 sin avatar
    Medlem siden
    May 2007
    Poster
    569
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Focalmann
    Aaahh, damn så irriterende! Nå var jeg sikker på at du kom med løsningen, og jeg fant AC3 Filteret med en gang også. Men tror du det hjalp? Har slitt med å få 5,1 lyd ut fra min Asus laptop helt siden jeg kjøpte den i desember ifjor... Flere glupe hoder som har prøvd forskjellige ting, uten at noe hjelper. Det er kun 2 kanals PCM stereo uansett hvilken avspiller jeg bruker,Mediaplayer, Mediaplayer Classic, VLC. Har vært inne på alt av instillinger. Kjører digital MiniToslink 3,5mm ut og rett i en Rxv-1700. Hvis jeg putter i en DVD i skuffen, får jeg 5,1 DD og DTS med en gang..?
    Får du 5.1 lyd om du spiller DVD fra PCen? I så fall er det helt garantert et softwareproblem, noe jeg tror det er uansett.

    Nå skal jeg ikke prøve å ødelegge noe for deg!! Men det jeg gjør de få gangene jeg får slike problemer, er å avinstallere alle mediaspillere og alle codec som jeg har på maskinen. Start maskinen på nytt, for så å legge inn software på nytt. Om ikke så lærerikt så er dette ofte enklere og kjappere enn feilsøking på hva som er galt.

    En laptop blir ofte brukt til mange forskjellige program, man laster til stadighet ned oppdateringer og dermed kan det være at enkelte program ikke samarbeider helt optimalt.

    Dette har i allefall fungert hos meg. Bruker du da K-lite pakken kan alle codec fjernes samtidig med få knappetrykk, og legges inn på nytt i siste versjon. Den er gratis og er satt sammen av de beste codekene på markedet.

    Du kan jo også prøve å oppdatere driverne til lydkortet. Men jeg tror ikke det er det som er problemet. Dette er nok en codekkrasj.

  13. #13
    Newcomer Focalmann sin avatar
    Medlem siden
    Dec 2004
    Poster
    133
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av amazon1969
    Får du 5.1 lyd om du spiller DVD fra PCen? I så fall er det helt garantert et softwareproblem, noe jeg tror det er uansett.

    Nå skal jeg ikke prøve å ødelegge noe for deg!! Men det jeg gjør de få gangene jeg får slike problemer, er å avinstallere alle mediaspillere og alle codec som jeg har på maskinen. Start maskinen på nytt, for så å legge inn software på nytt. Om ikke så lærerikt så er dette ofte enklere og kjappere enn feilsøking på hva som er galt.

    En laptop blir ofte brukt til mange forskjellige program, man laster til stadighet ned oppdateringer og dermed kan det være at enkelte program ikke samarbeider helt optimalt.

    Dette har i allefall fungert hos meg. Bruker du da K-lite pakken kan alle codec fjernes samtidig med få knappetrykk, og legges inn på nytt i siste versjon. Den er gratis og er satt sammen av de beste codekene på markedet.

    Du kan jo også prøve å oppdatere driverne til lydkortet. Men jeg tror ikke det er det som er problemet. Dette er nok en codekkrasj.
    Takker for svar :-) Stemmer helt sikkert at dette er et softwareproblem, og det er vel ikke noe helt nytt med Vista.... Har avinstallert K-Lite og installert på nytt, så nå får vi se hva som skjer da.

  14. #14
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Prøver codecene nå, sakk ska dere ha.

  15. #15
    Newcomer
    Medlem siden
    Jan 2005
    Poster
    72
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    du bruker vista ?

    Se under egenskaper/properties for lyd/høyttalere (sitter på jobb uten vista, så jeg kan ikke gå god for den nøyaktige benevningen)

    Der skal du få opp både vanlige høyttalere (om de er koblet til via analoge utganger) og digitalutgangen. Digitalutgang må settes som standard om du skal få dd/dts/wma dekodet i forsterker. Du trenger ikke en gang ac3 filter - selv om det neppe skader å installere det. Akkurat hva angår digitallyd er vista enklere en xp faktisk :-)

  16. #16
    Newcomer
    Medlem siden
    Mar 2008
    Poster
    9
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Lastet ned codecene, spiller av en DVD i både PowerDVD og Media Player Classic, men får bare ut lyd på 2 av høytalerene... Fillern.

    Nei, har Windows XP SP2

  17. #17
    Newcomer Cleeves sin avatar
    Medlem siden
    Sep 2004
    Poster
    224
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    I mediaplayer classic: Høyreklikk på bildet -> filters -> AC3 audio decoder -> og hak av for SPDIF

  18. #18
    Active
    Medlem siden
    Sep 2006
    Poster
    316
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Prøv FFDshow for audio isteden. Slet selv enormt med AC3filter. Fikk Dolby digital til å fungere, men DTS var det ikke snakk om.

    settings skal være:
    Codecs:
    AC3: SPDIF
    DTS: SPDIF

    under mixer/output:
    AC3 (SPDIF encode mode), skal være enabled.


    Skal fungere da.

  19. #19
    Newcomer
    Medlem siden
    Jul 2007
    Poster
    38
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg tror i utgangspunktet ikke man trenger noen codec eller decoder for dette, ettersom lyden ikke skal dekodes i pc'en. Den skal bare sendes rett til forsterkere for dekoding der. I PowerDVD satte jeg bare på "use SPDIF" og så alt var i boks i hvert fall.

    Kan være som noen har foreslått, at det er noen andre codecer som blander seg inn og ødelegger alt ved å dekode lyden et sted på vei ut av pc'en. Skal jo egentlig ikke være noe stort problem dette, i hvert fall ikke med PowerDVD, som er århundrets beste dvd-avspiller.

    .:vegard:.

  20. #20
    Expert AndersT2 sin avatar
    Medlem siden
    Feb 2004
    Poster
    5,463
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Normalt så vil lyd direkte fra DVD via optisk sendes korrekt.

    Men hvis det er andre ting som brukes, så vil man kun få stereo PCM fra den optiske. Da lydkortet ikke greier å lage en 5.1 strøm av lydinnholdet.

Side 1 av 2 1 2 SisteSiste

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •