HTPC med linux og XBMC - Side 4

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 4 av 5 FørsteFørste 1 2 3 4 5 SisteSiste
Viser resultater 61 til 80 av 86
  1. #61
    Active
    Medlem siden
    Aug 2008
    Poster
    392
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Det er alltid et slikt driverproblem med linux og desktop.
    Men realtek lydkortene (HD2600) skal i teorien være støttet. Men teori og praksis er ikke bestanig det samme

  2. #62
    Intermediate DrErling sin avatar
    Medlem siden
    Oct 2003
    Poster
    4,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeje, da var det gjort! Jeg har fått ubuntu+XBMC til å virke!

    kopierer bare svaret mitt fra forumet jeg fant løsningene på (LinuxQuestions.com)

    Asus HD2600pro graphics, AMD 64 4600+, 2GiB, Asus M3A32-mvp deluxe mainboard and ESI Juli@ soundcard. I plan to use the digital optial SPDIF output of the Juli@ card connected to my EAD DSP-1000 DAC.

    The cards are listed by default as quoted:
    Code:
    htpc@htpc-xbmc:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: Juli [ESI Juli@], device 0: ICE1724 [ICE1724]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: Juli [ESI Juli@], device 1: IEC1724 IEC958 [IEC1724 IEC958]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    I went down the "less /proc/asound/modules" road and got:
    Code:
    0 snd_hda_intel
    1 snd_ice1724
    /proc/asound/modules (END)
    I edited the alsa base entering "sudo gedit /etc/modprobe.d/alsa-base", filling in "options snd_hda_intel index=-2" under "# Prevent abnormal drivers from grabbing index 0"

    Rebooted. Ran aplay -l again which produced:
    Code:
    htpc@htpc-xbmc:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Juli [ESI Juli@], device 0: ICE1724 [ICE1724]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: Juli [ESI Juli@], device 1: IEC1724 IEC958 [IEC1724 IEC958]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    This means, at least, that my Juli@ now is device0. But no sound yet. I know for a fact that it is the "card 0, device 1" that gives sound. But now, when my soundcard is set as default, how can I make the digital optical output on that card default? (IEC1724 IEC958).

    I guess I found the sollution! Finally! After three re-installs and countless hours of testing/googling/terrorizing forums/asking the white out of the eye of #xbmc-linux members...
    I found it here.
    Just edited the code a bit to fit my hardware-problem.

    I had to edit the .asoundrc and change default soundcard from what seems to be the usual (0,0) to 0,1 by inserting this into .asoundrc:
    Code:
    pcm.!default {
    type asym
    playback.pcm {
    type plug
    slave.pcm "hw:0,1"
    }
    }
    and edit the output from XBMC from default/iec958 to default/default.

    When testing after this I was almost in heaven hearing terrible noise in my speakers, because then I knew that my DAC was fed with AC3 which it does not support :wink: (sollution was to remove support for AC3 and DD in XBMC output settings)

    Last night I gave up. When I came home this night and the only thing I did was editing the output of XBMC I finally understand how frustrated one can be over something one does not understand (in this case, Linux)

    Sweeet!

  3. #63
    Newcomer
    Medlem siden
    Sep 2004
    Poster
    46
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg har bestilt meg komponenter til HTPC nå, og mens jeg venter på at de skal bli levert så surfer jeg rundt for å finne ut hva jeg skal mate maskinen med.

    Pr idag ser det ut til å bli Ubuntu og XBMC, ser ut som om det er noe av det beste man kan få til idag. For min del er Windows uaktuelt (inntil alt annet er prøvd) fordi jeg ikke ønsker å bruke penger på det og ikke ønsker å piratkopiere.

    Jeg kan ingenting om XBMC fra før, så er veldig spent på dette. Er det støtte for avspilling av lastfm, youtube, hulu og/eller NRK på ubuntu m/XBMC?

    Er det noen som har forsøkt å bruke styre XBMC på linux med en Harmony (one) fjernkontroll? Erfaringer?

    Håper på tilbakemeldinger, så skal jeg love å komme med mine erfaringer så fort jeg har gjort meg noen

  4. #64
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av aragonjcw
    Jeg har bestilt meg komponenter til HTPC nå, og mens jeg venter på at de skal bli levert så surfer jeg rundt for å finne ut hva jeg skal mate maskinen med.

    Pr idag ser det ut til å bli Ubuntu og XBMC, ser ut som om det er noe av det beste man kan få til idag. For min del er Windows uaktuelt (inntil alt annet er prøvd) fordi jeg ikke ønsker å bruke penger på det og ikke ønsker å piratkopiere.

    Jeg kan ingenting om XBMC fra før, så er veldig spent på dette. Er det støtte for avspilling av lastfm, youtube, hulu og/eller NRK på ubuntu m/XBMC?

    Er det noen som har forsøkt å bruke styre XBMC på linux med en Harmony (one) fjernkontroll? Erfaringer?

    Håper på tilbakemeldinger, så skal jeg love å komme med mine erfaringer så fort jeg har gjort meg noen
    For å se hvilke plugins du har til xbmc kan du sjekke ut disse websidene:

    XBMCZone.com: The Place for XBMC Scripts and Plugins.
    XBMCScripts.com - Home

    Du kan bruke vilken fjernkontroll du vil egentlig, så lenge du har satt opp oppsettet riktig.

    Det enkelste er å sette opp linux med "windows mce fjernskontroll" og så sette opp harmony med tilsvarende.

  5. #65
    Intermediate DrErling sin avatar
    Medlem siden
    Oct 2003
    Poster
    4,087
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Så disse skriptene fungerer til både linux/osx/win setups?

    DrE

  6. #66
    Intermediate cowboy bebop sin avatar
    Medlem siden
    Jun 2005
    Poster
    1,427
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg sliter med at XBMC avsluttes samme sekundet som jeg starter det. Alt jeg ser er ett sort vindu i omtrent 2sekunder, så er det tilbake til bakgrunnsbildet...

    Jeg finner heller ikke ut hva som forårsaker dette.

    Kjører med Ubuntu 8.04, uten andre programmer installert.

    Jeg prøvde meg på denne guiden:
    Installing Xbox Media Center (XBMC) On Ubuntu 8.04 | HowtoForge - Linux Howtos and Tutorials
    Alt gikk fint, men det vil altså ikke starte.

  7. #67
    Newcomer
    Medlem siden
    May 2004
    Poster
    45
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    HD-DVD og musikkbibliotek på XBMC?

    Tenkte å bygge htpc i helgen og vurderer hvilket OS/Software jeg skal gå for. XBMC ser spennende ut, og jeg vil helst slippe å kjøpe Windows-lisens

    Men jeg har 2 krav, som er absolutte:
    1. HD-DVD avspilling (har ikke ekstern spiller, så dette må fungere)

    2. Oppsettet må håndtere et stort musikkbibliotek (ca 200GB). Dvs. det må være brukervennlig, og det kan heller ikke være helt sirup pga. store mengder..

    Så spørsmålet blir egentlig om XBMC er noe for meg? (Evt. om noen har noen alternativer tas det imot med takk..)

  8. #68
    Intermediate Baldrick sin avatar
    Medlem siden
    Nov 2003
    Poster
    1,950
    Takk & like
    Nevnt
    1 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg har Windows og ikke Linux så svarer utifra det, men regner med det er det samme for Linux også:

    Sitat Opprinnelig postet av aragonjcw
    Jeg kan ingenting om XBMC fra før, så er veldig spent på dette. Er det støtte for avspilling av lastfm, youtube, hulu og/eller NRK på ubuntu m/XBMC?
    Ja det er full støtte for dette + f.eks. styring/streaming av Dreambox dersom en har dette.

    Sitat Opprinnelig postet av aragonjcw
    Er det noen som har forsøkt å bruke styre XBMC på linux med en Harmony (one) fjernkontroll? Erfaringer?
    Så lenge du har en IR mottager som fungerer i OS vil den 99% sikkert fungerer også i XBMC, men krever litt fikling før det fungerer 100%. Jeg bruker selv MCE mottaker og org Xbox fjernkontroll, da fungerer det helt likt som på Xbox m/XBMC

    Sitat Opprinnelig postet av lavik
    1. HD-DVD avspilling (har ikke ekstern spiller, så dette må fungere)
    Mener du virkelig hd-dvd eller tenker du på HD filer alt i alt? Tror ikke det pr idag er skikkelig støtte for BlueRay men tror en får spillt av HD-DVD (men dette betyr jo lite siden det er slutt på HD-DVD), hd filer i X264, VMW o.l. fungerer smertefritt så lenge en har CPU kraft nok.

    Sitat Opprinnelig postet av lavik
    Oppsettet må håndtere et stort musikkbibliotek (ca 200GB). Dvs. det må være brukervennlig, og det kan heller ikke være helt sirup pga. store mengder..
    I dag er ikke 200gb særlig mye (har selv vesentlig mye mer) og det er ikke noe problem, flaskehalsen er isåfall HW, XBMC i seg selv har ikke problem med slike mengder.

  9. #69
    Intermediate Kane sin avatar
    Medlem siden
    May 2004
    Poster
    3,246
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har selv bygd meg en festelig liten sak som je ghar lagt inn XBMC på. Kjører "Tiny XP" i bunnen, å dette funker helt utmerket. Med nyeste BUILD av Beta 2 er også problemet med at CPU gikk på 50% når man bare var rundt i menyen på XBMC. Har satt det opp så jeg streamer alle filmer å serier fra en annen PC. Har også satt opp så XBMC går online og laster ned thumbs og også PLOT og skuespiller liste. Dette funket også helt uten problemer.

    Mitt problem kommer når jeg prøver å gjøre det samme med serier. Den funker da også en stund, hvor den laster ned masse snacks til hver serie, bla.a en liten linje eller to om hva hver episode handler om. Problemet er at den har en tendens til å slutte å scanne etter en stund. Tar kanskje enn 6 - 7 episoder, så skjer ikke noe. Så må jeg restarte hele XBMC å scan for changes, så forsetter den en stund, så må jeg gjøre det samme igjen. Litt tungvindt med tanke på jeg har 3TB med diverse serier jeg kunne tenkt meg å gjort dette med.

    Noen som har noen ideer?
    Yamaha CX-A5000, Sherbourn PA 5-200, Arendal Sound 1723 Tower, Arendal Sound 1723 Center, 3 x Arendal Sound 1723 SUB3, SVS SSS-01

  10. #70
    Intermediate frippsi sin avatar
    Medlem siden
    Feb 2007
    Poster
    510
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Kane
    Har selv bygd meg en festelig liten sak som je ghar lagt inn XBMC på. Kjører "Tiny XP" i bunnen, å dette funker helt utmerket. Med nyeste BUILD av Beta 2 er også problemet med at CPU gikk på 50% når man bare var rundt i menyen på XBMC. Har satt det opp så jeg streamer alle filmer å serier fra en annen PC. Har også satt opp så XBMC går online og laster ned thumbs og også PLOT og skuespiller liste. Dette funket også helt uten problemer.

    Mitt problem kommer når jeg prøver å gjøre det samme med serier. Den funker da også en stund, hvor den laster ned masse snacks til hver serie, bla.a en liten linje eller to om hva hver episode handler om. Problemet er at den har en tendens til å slutte å scanne etter en stund. Tar kanskje enn 6 - 7 episoder, så skjer ikke noe. Så må jeg restarte hele XBMC å scan for changes, så forsetter den en stund, så må jeg gjøre det samme igjen. Litt tungvindt med tanke på jeg har 3TB med diverse serier jeg kunne tenkt meg å gjort dette med.

    Noen som har noen ideer?
    Jeg sliter litt med samme problemet som deg. Jeg bruker da Mac versjonen. Har forstått det slik at navngivingen/filstrukturen må være ganske konsekvent.
    Altstå: Serienavn -> Sesong -> osv..
    men som sagt, jeg klør meg i hue av dette jeg og.

  11. #71
    Newcomer
    Medlem siden
    May 2004
    Poster
    45
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Baldrick
    Mener du virkelig hd-dvd eller tenker du på HD filer alt i alt? Tror ikke det pr idag er skikkelig støtte for BlueRay men tror en får spillt av HD-DVD (men dette betyr jo lite siden det er slutt på HD-DVD), hd filer i X264, VMW o.l. fungerer smertefritt så lenge en har CPU kraft nok.
    Jepp, jeg mener HD-DVD. Jeg har, og kjenner andre som har kjøpt inn en haug av disse, og vil se film i HD billig.. Blu-ray bør selvfølgelig også støttes. Men etter hva jeg skjønner støttes ikke hardware-akselerasjon fra GPU i Linux?

    Sitat Opprinnelig postet av Baldrick
    I dag er ikke 200gb særlig mye (har selv vesentlig mye mer) og det er ikke noe problem, flaskehalsen er isåfall HW, XBMC i seg selv har ikke problem med slike mengder.
    Nei, det er kanskje ikke veldig mye utfra dagens standard, men det er nok av musikkavspillere for Windows (bl.a. WMP11 og iTunes) som blir rimelig trege når det er snakk om 40-50.000 filer.. Derfor vil jeg bare forsikre meg om at dette ikke er tilfelle i XBMC. Grensesnittet for å filtrere og finne frem musikken er også viktig når det er snakk om tusenvis av filer.. og dette er heller ikke alltid like godt på ulike avspillere..

  12. #72
    Active
    Medlem siden
    Aug 2008
    Poster
    392
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av lavik
    Jepp, jeg mener HD-DVD. Jeg har, og kjenner andre som har kjøpt inn en haug av disse, og vil se film i HD billig.. Blu-ray bør selvfølgelig også støttes. Men etter hva jeg skjønner støttes ikke hardware-akselerasjon fra GPU i Linux?
    Direkte avspilling av Blu-ray støttes ikke under linux pga. HDCP. ATI skulle ha kommet med HDCP støtte i de nye Catalyst driverene i oktober, men oktober oppgraderingen innehold bare patcher.

  13. #73
    Intermediate Kane sin avatar
    Medlem siden
    May 2004
    Poster
    3,246
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av frippsi
    Jeg sliter litt med samme problemet som deg. Jeg bruker da Mac versjonen. Har forstått det slik at navngivingen/filstrukturen må være ganske konsekvent.
    Altstå: Serienavn -> Sesong -> osv..
    men som sagt, jeg klør meg i hue av dette jeg og.
    Har funnet ut dette funker best for meg

    Serier\
    -------Dexter\
    --------------Sesong 1\
    ------------------------S01.e01.mkv

    Selv med alt lagt i mapper på denne måten, så henger søket seg innimellom. Må da som sagt restarte XBMC, og så ta scan for changes, så forsetter den. Håper dette blir fikset i Beta 3 som etterhvert kommer.
    Yamaha CX-A5000, Sherbourn PA 5-200, Arendal Sound 1723 Tower, Arendal Sound 1723 Center, 3 x Arendal Sound 1723 SUB3, SVS SSS-01

  14. #74
    Newcomer
    Medlem siden
    Sep 2004
    Poster
    46
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cowboy bebop
    Jeg sliter med at XBMC avsluttes samme sekundet som jeg starter det. Alt jeg ser er ett sort vindu i omtrent 2sekunder, så er det tilbake til bakgrunnsbildet...

    Jeg finner heller ikke ut hva som forårsaker dette.

    Kjører med Ubuntu 8.04, uten andre programmer installert.

    Jeg prøvde meg på denne guiden:
    Installing Xbox Media Center (XBMC) On Ubuntu 8.04 | HowtoForge - Linux Howtos and Tutorials
    Alt gikk fint, men det vil altså ikke starte.
    Jeg hadde samme problemet som deg. Løsningen for meg var å aktivere driveren til skjermkortet. Denne er proprietær og er derfor ikke aktivert som default.. Lykke til!

  15. #75
    Intermediate cowboy bebop sin avatar
    Medlem siden
    Jun 2005
    Poster
    1,427
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av aragonjcw
    Jeg hadde samme problemet som deg. Løsningen for meg var å aktivere driveren til skjermkortet. Denne er proprietær og er derfor ikke aktivert som default.. Lykke til!
    Takk for tipset! Men du, hvordan aktiverer jeg den driveren?
    Jeg har nettopp begynt å sette meg inn i Linux, og har desverre ikke alt sånt på plass enda...

  16. #76
    Newcomer
    Medlem siden
    Sep 2004
    Poster
    46
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cowboy bebop
    Takk for tipset! Men du, hvordan aktiverer jeg den driveren?
    Jeg har nettopp begynt å sette meg inn i Linux, og har desverre ikke alt sånt på plass enda...
    System->Administrasjon->Hardware Drivers

  17. #77
    Intermediate cowboy bebop sin avatar
    Medlem siden
    Jun 2005
    Poster
    1,427
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av aragonjcw
    System->Administrasjon->Hardware Drivers
    Der er det ikke noe som helst... Altså den er tom.

  18. #78
    Newcomer
    Medlem siden
    Sep 2004
    Poster
    46
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cowboy bebop
    Der er det ikke noe som helst... Altså den er tom.
    Da vet jeg ikke.. Da kan det hende du må på leting etter driver eller noe sånt.. Jeg har omtrent 2 dagers erfaring med ubuntu selv, så er ikke akkurat noen ekspert

  19. #79
    Newcomer
    Medlem siden
    Sep 2004
    Poster
    46
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cowboy bebop
    Der er det ikke noe som helst... Altså den er tom.
    Det har kommet noen tips her:
    http://avforum.no/forum/generell-htp...ml#post1027634

  20. #80
    Intermediate cowboy bebop sin avatar
    Medlem siden
    Jun 2005
    Poster
    1,427
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Problem løst: Dårlig grafikkort byttet i et bedre ett. Så virker alt som det skal.

    Neste problem: Jeg får ikke autostartet XBMC ved oppstart... Jeg har prøvd diverse toturials på nett, men får dem ikke til å virke.

    for eksempel denne:
    Auto start XBMC on Ubuntu - HOWTO - XBMC Community Forum
    Der står det "Using your favourite editor, create a file in your home directory called .xinitrc that contains the following:"

    Hvor finner jeg så en editor? Jeg aner ikke hvor den er eller hvordan man bruker dem, dermed er det ganske vanskelig å lage seg en fil...

Side 4 av 5 FørsteFørste 1 2 3 4 5 SisteSiste

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •