Utestående issues med Mediaportal og DVB-C.

Sponsorer:
Takk Takk:  0
Like Like:  0
Viser resultater 1 til 8 av 8
  1. #1
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Utestående issues med Mediaportal og DVB-C.

    Hei,

    Som nevnt tidligere har jeg bygget en Mediaportal box med DVB-C og softcam.

    Etter mye finkling, prøving og herjing er jeg _nesten_ i mål.

    Følgende er utestående som jeg håper noen har tips rundt:

    1. Stabilitet på timeshift. Denne henger etter en stund. spesielt på Discovery.

    (Tilsvarende på opptak)

    2. Lyd på Animal Planet, CNN

    (Må benytte Dscaler lyd codec, ellers får jeg ikke lyd.. Why ?)

    3. Lyd på Cartoon Network og Eurosport.

    (Ser ut som jeg får forskjellige språkene mixet inn i samme lydstream. Venstre front har svensk, høyre front har dansk etc)

    4. Decode Nrk1, Nrk2 og Nrk3

    (Ser ikke ut som softcam mixen min funker i MediaPortal på disse kanalene. Funker fint i andre DVB program med softcam)

    5. Subtitles på Animal Planet

    (Funker fint på de andre kanalene)

    Kjører for tiden 2.2.3 RC1

    Min tråd

  2. #2
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av T1ger
    Hei,

    Som nevnt tidligere har jeg bygget en Mediaportal box med DVB-C og softcam.

    Etter mye finkling, prøving og herjing er jeg _nesten_ i mål.

    Følgende er utestående som jeg håper noen har tips rundt:

    1. Stabilitet på timeshift. Denne henger etter en stund. spesielt på Discovery.

    (Tilsvarende på opptak)

    2. Lyd på Animal Planet, CNN

    (Må benytte Dscaler lyd codec, ellers får jeg ikke lyd.. Why ?)

    3. Lyd på Cartoon Network og Eurosport.

    (Ser ut som jeg får forskjellige språkene mixet inn i samme lydstream. Venstre front har svensk, høyre front har dansk etc)

    4. Decode Nrk1, Nrk2 og Nrk3

    (Ser ikke ut som softcam mixen min funker i MediaPortal på disse kanalene. Funker fint i andre DVB program med softcam)

    5. Subtitles på Animal Planet

    (Funker fint på de andre kanalene)

    Kjører for tiden 2.2.3 RC1

    Min tråd
    Update:

    Ahh, hard arbeid gir resultater.

    1. Har blitt mye bedre. Har latt timeshift stå på Discovery en natt og den var forsatt stabil. Usikker på hva av ulike tiltak som evt som bidro her. Misstenker "autoecm=1" i softcam.

    2. Jaja, så vet jeg ikke hvorfor MPA lyd codec'en ikke funker. Men de fleste av de andre funker så..

    3. Uløst.. Ser samme avviket i alle DVB program jeg tester.. (Bare jeg som sliter med dette ?). Legger på todo lista...

    4. autoecm=1 i softcam..

    5. Uløst, riktig pid i config.. Mere arbeid/debug må til..

    Kansje vi skulle orke å oppgradere til svn og/eller TV server...

  3. #3
    Intermediate
    Medlem siden
    Sep 2005
    Poster
    513
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av T1ger
    Update:

    Ahh, hard arbeid gir resultater.

    1. Har blitt mye bedre. Har latt timeshift stå på Discovery en natt og den var forsatt stabil. Usikker på hva av ulike tiltak som evt som bidro her. Misstenker "autoecm=1" i softcam.

    2. Jaja, så vet jeg ikke hvorfor MPA lyd codec'en ikke funker. Men de fleste av de andre funker så..

    3. Uløst.. Ser samme avviket i alle DVB program jeg tester.. (Bare jeg som sliter med dette ?). Legger på todo lista...

    4. autoecm=1 i softcam..

    5. Uløst, riktig pid i config.. Mere arbeid/debug må til..

    Kansje vi skulle orke å oppgradere til svn og/eller TV server...
    Takk for update...hadde jeg hatt penger for tiden skulle jeg hjulpet deg. Men har verken CAM eller DVB-C kort, og lønningene kommer ikke fort nok for tiden, så ....

    Apropos TV-server er det rimelig kjapt å installere (drit å sette seg inn i første gangen med SQL-server osv, men egentlig ganske straight forward). Er mulig den er mer stabil...uten noe godt grunnlag for å si det

    SVN-buildsene er ihvertfall megakjapt å bruke. Men stabiliteten dems er jo veldig opp og ned såvidt jeg har fått med meg.

  4. #4
    Newcomer
    Medlem siden
    Jul 2005
    Poster
    36
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Jeg kjører nå 0.2.3 RC3
    Har floppy-DVB C med hardware cam, og har noen av de samme problemene. Spesielt punkt 2,3 og 5. Testet TVE0.3 for et par uker siden, og disse punktene var fortsatt et problem der. Testet ikke det nye subtitles filteret, som muligens kunne har løst det. Den SVN jeg testet var veldig ustabil på timeshift og opptak, så jeg gikk tilbake til RC3 og TVE0.2.

    Aldri hatt noen problemer med NRK1,2 og 3

  5. #5
    Newcomer
    Medlem siden
    Nov 2004
    Poster
    72
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    MP 0.2.3 RC3 + SVN, FloppyDTV-S

    Har problem 1. Får ofte heng på Discovery ved reklamepause. Mistenker feil i DVB-strømmen som ikkje MP håndterer.

    Ang 3, så har eg hatt det, men det har med codec å gjere. Bruker no nVidia PureVideo, og det fungerer bra. Problemet er sendingar i mono der berre ein lydkanal vert brukt. Dersom codecen ikkje oppfattar dette, får vi ein lydkanal i venstre og ein i høgre høgtalar.

    Ellers har eg eit problem som eg antar har med deinterlacing å gjere. Kan nesten virke som om feil bilderammer blir kombinert, slik at om eg tar pause på f.eks ein rulletekst ser det ut som om den har skygge, eller er "dobbel", på en måte. Har prøvd "alt". Codecs, ulike nVidia og ATI skjermkort, FFDshow, innstillingar i skjermdriver, VMR-innstillingar, reinstallasjon av XP/MP, og har egentleg slutta å tenke på det. Har ikkje testa med EVR i staden for VMR, så det er fortsatt eit lite håp....

    -----------
    Leon

  6. #6
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Tomas78
    Takk for update...hadde jeg hatt penger for tiden skulle jeg hjulpet deg. Men har verken CAM eller DVB-C kort, og lønningene kommer ikke fort nok for tiden, så ....

    Apropos TV-server er det rimelig kjapt å installere (drit å sette seg inn i første gangen med SQL-server osv, men egentlig ganske straight forward). Er mulig den er mer stabil...uten noe godt grunnlag for å si det

    SVN-buildsene er ihvertfall megakjapt å bruke. Men stabiliteten dems er jo veldig opp og ned såvidt jeg har fått med meg.
    Er nå bare 500 lapp for et enkelt dvb-c kort..

    Er jo noen gratis FTA kanaler, Tv3 f.eks.. Du burde kunne bruke EPG'n etc..

    Hivde inn rc3 forrige helg, og den løse ingen av utfordringene.

    Ser ikke noe spesielt behov for tv server'n så langt, sist jeg testa var den rimelig ustabil og litt bloated.

    Har planer om å sette opp kompiler og mekke min egen build.

  7. #7
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av audunhystad
    Jeg kjører nå 0.2.3 RC3
    Har floppy-DVB C med hardware cam, og har noen av de samme problemene. Spesielt punkt 2,3 og 5. Testet TVE0.3 for et par uker siden, og disse punktene var fortsatt et problem der. Testet ikke det nye subtitles filteret, som muligens kunne har løst det. Den SVN jeg testet var veldig ustabil på timeshift og opptak, så jeg gikk tilbake til RC3 og TVE0.2.

    Aldri hatt noen problemer med NRK1,2 og 3
    Kjører RC3 nå uten at det har løst noe spesielt.
    Ligger unna SVN og TV server inntill videre.

    Punkt 2 og 3 er løst ved å bytte lydcodec. (Se svar i tråden her) Bruker Nvidia Purevideo lydcodec her nuh og det funker perfekt.

    Punkt 5 er vel gjenstående. har funnet en subtitle "plugin" som benytter samme API som softc@m. Testa litt med fikk bare segfault.. Skal dille litt til. Overlever jo outen, men hadde vært stas å fått det perfekt.

    Ellers enig i at de nyeste er litt vel ustabile.

    Takk for innspillene, da vet jeg at det ikke ligger i softc@m

    Ser ut som NRK kanalene kommer med 2 stykk ECM i loggen.. Jobber med fix.. 4-6 sekunder på kanal bytte p.d.d.

  8. #8
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    1,115
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av LeonGjerland
    MP 0.2.3 RC3 + SVN, FloppyDTV-S

    Har problem 1. Får ofte heng på Discovery ved reklamepause. Mistenker feil i DVB-strømmen som ikkje MP håndterer.

    Ang 3, så har eg hatt det, men det har med codec å gjere. Bruker no nVidia PureVideo, og det fungerer bra. Problemet er sendingar i mono der berre ein lydkanal vert brukt. Dersom codecen ikkje oppfattar dette, får vi ein lydkanal i venstre og ein i høgre høgtalar.

    Ellers har eg eit problem som eg antar har med deinterlacing å gjere. Kan nesten virke som om feil bilderammer blir kombinert, slik at om eg tar pause på f.eks ein rulletekst ser det ut som om den har skygge, eller er "dobbel", på en måte. Har prøvd "alt". Codecs, ulike nVidia og ATI skjermkort, FFDshow, innstillingar i skjermdriver, VMR-innstillingar, reinstallasjon av XP/MP, og har egentleg slutta å tenke på det. Har ikkje testa med EVR i staden for VMR, så det er fortsatt eit lite håp....

    -----------
    Leon
    Problem 1.

    Ahh, stemmer det er jo i reklame pausen det skjer.. Merkelig.. Ser ingenting i loggen.. Det er vel støtte for annen demuxer i svn ? Mulig den funker bedre.

    Problem 3.

    Jepp, stemmer Funker gull nå.

    Angående Interlace...
    Funker gull for meg.. Får du samme i f.eks gb-pvr e.l ?

    Har du et skjermskudd ?

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •