Ytelse for 1080p avspilling - hvor er flaskehalsen ?

Sponsorer:
Takk Takk:  0
Like Like:  0
Side 1 av 2 1 2 SisteSiste
Viser resultater 1 til 20 av 22
  1. #1
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Ytelse for 1080p avspilling - hvor er flaskehalsen ?

    Har et klipp som er rippet fra en 1080p HD-DVD kilde.

    Codec : x264, fps = 23,976 , Bitrate = 8080 kbps.

    HTPC'en min klarer ikke å spille av dette klippet smooth. Det er en Core 2 Duo, E6300, som altså kjører 1.86Ghz. Maskinen har 1GB ram. Skjermkort - MSI Geforce 7600 GT. Klippet starter smooth, men stopper så helt, så henter det seg inn igjen og blir smooth noen sekunder før det henger helt igjen. Til slutt tryner VLC. Testet først i den oppløsningen jeg kjører til vanlig - 1980x1080 mot min Sony KDL-W2000, og deretter i 1280x720. Samme resultat.


    Kopierte så klippet over på min stasjonære PC. Den kjører en AMD Athlon X2 4400+, 2GB RAM og et Geforce 7800 GT. Her spiller klippet helt fint i 1280x1024.

    Det jeg da lurer på er - hvor er flaskehalsen på HTPC'en min ? Jeg monitorerte CPU bruken på HTPC'en mens jeg spilte av klippet - og det lå aldri over 50%. Så det er neppe CPU'en. Siden jeg har samme type harddisk i begge maskinene tror jeg heller ikke at dette er problemet.

    Spørsmålet er da : Skjermkort eller minne (edit : altså - er det for lite med 1GB RAM...) - hva tror dere ?....


    cozmo

  2. #2
    Moderator striky sin avatar
    Medlem siden
    Apr 2003
    Sted
    Vestfold
    Poster
    3,296
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Mulig VLC/dekoderen kun benytter seg av den ene prosessorkjerna? Sjekk CPU-monitoringen på de to grafene for kjerner, hvis den ene er på topp så er det tilfelle.

  3. #3
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av striky
    Mulig VLC/dekoderen kun benytter seg av den ene prosessorkjerna? Sjekk CPU-monitoringen på de to grafene for kjerner, hvis den ene er på topp så er det tilfelle.
    Hvordan får jeg opp grafen for begge kjernene ? I task manager ser jeg muligens bare en kjerne ? Evt annet program jeg må bruke ?....

  4. #4
    Intermediate Rikky sin avatar
    Medlem siden
    Dec 2002
    Poster
    2,103
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Begge grafene skal komme opp i task manager -> performance.

  5. #5
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Rikky
    Begge grafene skal komme opp i task manager -> performance.
    Huh ? Ser bare en graf uansett om jeg velger "one graph, all cpus" eller "one graph per cpu"...

    Ser bare en graf på athlon x2 maskinen min også....Misser jeg noe heeelt essensielt her ?...

  6. #6
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cozmo
    Huh ? Ser bare en graf uansett om jeg velger "one graph, all cpus" eller "one graph per cpu"...

    Ser bare en graf på athlon x2 maskinen min også....Misser jeg noe heeelt essensielt her ?...
    Der fikk jeg opp begge ja, måtte velge den ene, og så den andre.

    Men nå gir jeg opp - nå klarer ikke X2 pc'en å spille av filmen smooth heller. Er antagelig noe med klippet i seg selv da

    EDIT :

    På HTPC'en observerer jeg at den ene kjerna går i taket hver gang det hakker. Den kjernen spiker mellom 10 og 100%. Den andre kjerna ligger jevnt på på maks 20%. Så det er åpenbart at VLC ikke klarer å utnytte CPU'en ordentlig. Takk for at du guidet meg på riktig spor før jeg løp av gårde og bestilte mer RAM. Mulig jeg mangler en CPU-driver ?.....

  7. #7
    Newcomer bele sin avatar
    Medlem siden
    Jan 2005
    Poster
    163
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hva er den encode'et i H264 x264 og hvilket lydformat er det på klippet ?

  8. #8
    Intermediate thunderstorm77 sin avatar
    Medlem siden
    May 2005
    Poster
    677
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cozmo
    Der fikk jeg opp begge ja, måtte velge den ene, og så den andre.

    Men nå gir jeg opp - nå klarer ikke X2 pc'en å spille av filmen smooth heller. Er antagelig noe med klippet i seg selv da

    EDIT :

    På HTPC'en observerer jeg at den ene kjerna går i taket hver gang det hakker. Den kjernen spiker mellom 10 og 100%. Den andre kjerna ligger jevnt på på maks 20%. Så det er åpenbart at VLC ikke klarer å utnytte CPU'en ordentlig. Takk for at du guidet meg på riktig spor før jeg løp av gårde og bestilte mer RAM. Mulig jeg mangler en CPU-driver ?.....
    Jeg har nesten samme oppsett og har absolutt ingen problemer med avspilling. PC'n din skal være mer enn kraftig nok. Jeg ville forsøkt med ulike dekodere og avspillingsprogrammer. Jeg får meget bra resultat med Nero Showtime (demo er tilgjengelig). PowerDVD 7.2 spiller HD-DVD uten problemer.

    Det er stor forskjell på dekodere, VLC funker dårlig hos meg.

  9. #9
    Moderator striky sin avatar
    Medlem siden
    Apr 2003
    Sted
    Vestfold
    Poster
    3,296
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cozmo
    På HTPC'en observerer jeg at den ene kjerna går i taket hver gang det hakker. Den kjernen spiker mellom 10 og 100%. Den andre kjerna ligger jevnt på på maks 20%. Så det er åpenbart at VLC ikke klarer å utnytte CPU'en ordentlig. Takk for at du guidet meg på riktig spor før jeg løp av gårde og bestilte mer RAM. Mulig jeg mangler en CPU-driver ?.....
    Det er avspilleren og/eller dekoderen som styrer CPU-bruken. Personlig har jeg dårlige erfaringer med VLC til HD-materiale.

    Last ned en prøveversjon av Zoom Player (eller Media Player Classic), og prøv flere forskjellige dekodere til det klippet, ffdshow eller CoreAVC (sistnevnte er å foretrekke for høyere ytelse).

  10. #10
    Intermediate
    Medlem siden
    Sep 2004
    Poster
    870
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har du installert riktig decoder? Jeg hadde samme type problem med en lignende fil. (I .mkv). Etter jeg installerte ffdshow så spilte den smooooooth.
    Bruker Media Player Classic forøvrig...

  11. #11
    Newcomer Rottweiler sin avatar
    Medlem siden
    Dec 2004
    Poster
    107
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hvilken version av VLC har du? Version 8.6 ga store forbedringer hos meg....
    http://avforum.no/myhometheater/Rottweiler
    Forforsterker: Yamaha RX-V1800,Effektforsterker: Emotiva XPA-3, Dac: Hegel H2, Sub kalibrering: DSPeaker Anti Mode 8033, Cinema Videoprossesor: Darbee Darblet, Høyttalere: Front: Klipsch RF 82 MKII, Senter: Klipsch RC 62 MKII, Surr.: Klipsch RS 52 MKII, Sub: SVS PB12-NSD DSP, Prosjektor: Sony VPL-HW50, Lerret: DreamScreen V2 DynaGrey Black 77", Plasma TV: Panasonic TX-P50UT50Y, HTPC: Spotify og HD filmer
    Universal fjernkontroll: Logitech Harmony 885

  12. #12
    Intermediate
    Medlem siden
    Jan 2004
    Poster
    1,066
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Se til at grafikkortet er satt til 50Hz og ikke 60.

  13. #13
    Intermediate
    Medlem siden
    Nov 2006
    Poster
    538
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Har selv dååårlig erfaring med VLC når det gjelder å spille av HD filmer/klipp!
    Til og med windows mediaplayer gjør en bedre jobb

    (Har forrestn VLC Versjon 0.8.5).. orker ikke oppdatere nå for å sjekke om det blir bedre

  14. #14
    Intermediate
    Medlem siden
    Sep 2004
    Poster
    870
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Hvordan går det cozmo? Nå har du fått mange tips. Er det noe som hjelper?

  15. #15
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av BigZ
    Hvordan går det cozmo? Nå har du fått mange tips. Er det noe som hjelper?
    Hei hei!
    Tusen tusen takk for alle tipsene! Jeg ble desverre opptatt i går kveld og fikk ikke testet noe mere (madammen er ikke alltid begeistret for nerding i timesvis :? :wink: )

    Godt å høre at ekspertene her mener at burken min er kraftig nok. Som andre her påpeker - det er en .mkv fil. Grunnen til at jeg åpnet den i VLC var vel egentlig at den ikke lot seg åpne i MediaPlayer, ei heller i PowerDVD. Andre avspillere hadde jeg ikke inne.
    Jeg testet forøvrig media player classic på samme klippet - men det hakket noe helt forferdelig på X2 maskinen. Fikk ikke testet dette på Core2Duo maskinen.

    Skjønner at det er ffdshow som gjelder ? Gleder meg allerede til å teste dette når jeg kommer hjem!

    Angående VLC versjon som det ble spurt om tidligere - jeg tror det er VLC 0.8.4 - så det er ikke den nyeste. Grunnen til dette er noe streaming greier jeg har drevet og testet. Men skal oppgradere versjon og teste senere.

    cozmo

  16. #16
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av Plasmaboy
    Se til at grafikkortet er satt til 50Hz og ikke 60.
    Jaha ? På X2 maskinen har jeg en gammel CRT skjerm. Å kjøre denne i 50Hz tror ikke blir noen suksess
    HTPC'en er som nevnt koblet til en Sony KDL-40-2000W. Denne kjører som nevnt 1920x1080 i 60Hz. Kan jo alltids prøve å sette ned til 50Hz, men det hjalp jo heller ikke å kjøre ned til 1280x720 i 60Hz , så.......

  17. #17
    Intermediate magnuswb sin avatar
    Medlem siden
    Jan 2006
    Poster
    1,695
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Siste versjon har visst bedre kodeker og fungerer klart bedre... Etter det jeg har hørt..

    anbefaler heller media player classic+core avc.

  18. #18
    Active cozmo sin avatar
    Medlem siden
    Dec 2005
    Poster
    348
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Da har jeg testet litt mer....Installerte først CoreAVC og prøvde med Media Player Classic. Samme resultat før og etter instalasjon av CoreAVC - masse mpeg blokking og greier. Lastet ned Zoom Player - den klarte ikke åpne fila en gang - satt i gang en sinnsyk aktivitet på harddisken akkurat som den prøvde å scanne hele klippet (mange giga).

    Mistenker at MPC ikke klarte å bruke coreAVC codec'en - hvordan setter man opp dette ?

    Fortsatte uansett med å laste ned ffdshow - og installerte mer eller mindre med default settings. Da ble det andre boller når jeg spilte av med media player classic - plutselig begynte ting å skli og ting så veeldig pent ut :-D :-D

    Har jo lest utallige tråder om konfigurasjon og tweaking ffdshow - så jeg regner med at det sikkert er noe hente her. Rakk ikke teste så så mye mer i går - men umiddelbar reaksjon er at ffdshow+mpc ser ut til å være gulloppskriften inntil videre.

    Takker for alle innspill og tips så langt!

    cozmo

  19. #19
    Intermediate
    Medlem siden
    Sep 2004
    Poster
    870
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Sitat Opprinnelig postet av cozmo
    Fortsatte uansett med å laste ned ffdshow - og installerte mer eller mindre med default settings. Da ble det andre boller når jeg spilte av med media player classic - plutselig begynte ting å skli og ting så veeldig pent ut :-D :-D

    Har jo lest utallige tråder om konfigurasjon og tweaking ffdshow - så jeg regner med at det sikkert er noe hente her. Rakk ikke teste så så mye mer i går - men umiddelbar reaksjon er at ffdshow+mpc ser ut til å være gulloppskriften inntil videre.
    cozmo
    Ja, hva sa jeg?

  20. #20
    Newcomer
    Medlem siden
    Jan 2007
    Poster
    13
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Vil installere ffdshow

    Hei,

    Har alltid brukt Ace Megacodec Pack, men har no lyst til å prøve ffdshow. Ein del filmar (divx, xvid) hakkar ein del, men har ofte trudd det har vore dårlege rips. Har hørt at det kan være vanskelig å avinstallere Ace Megacodec. Noken som har erfaring med dette? Er det i så fall mulig å velge slik at Media Player Classic ikkje brukar noko av Ace Megacodec, men heller ffdshow. Er litt redd for å bytte til ffdshow, så lenge Ace fungerer brukbart.

    mvh
    Gazza

Side 1 av 2 1 2 SisteSiste

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •