The Green Button - S3 Standby - Hardware & Software solution

"I've just spent hours getting s3 to work right on my new machine, so while it is fresh in my mind, here is all I learned:

I can now sleep with fans and all powered down, I can resume from remote, and my wireless keyboard and mouse DO NOT power up the system!

(This is not the only way, but it worked for me)


1. Setup hardware (MB jumpers)

2. Setup Bios

3. Add reg setting

4. Configure devices you want to be able to wake up

5. Windows Changes

6. Troubleshooting

1. Hardware setup

For your remote to be able to resume the system, it needs power. This power comes from the MB and must be enabled by a jumper. {My notes are from an ASUS MB, others should have similar} Look up the manual for your MB "USB device wake-up". The jumper needs to be on "+5VSB".


You may have multi jumpers for different pairs of USB ports. You only need to turn on the ones for IR receiver. I recommend Keyboard and mouse too (see troubleshooting for reason).
Make sure you hard power off (switch on the back of power supply or pull the power cable) - these jumpers are live when the system is 'soft' off
Some new MB are always +5VSB (Asus A8N-SLI deluxe is one)
2. Setup the BIOS

2.a If you have any suspend setting, set them to s3 only (or s1 & s3)
2.b Turn on ACPI 2.0 support (and any other advance power support options)
2.c Turn off Wake on LAN, ps2 keyboard... basically everything
3. Add Reg Setting

Add HKLM->SYSTEM -> Current Control Set -> Services ->USB (A Key)
Add Dword value USBBIOSx=0
4. Configure Devices for wakeup

In device manager:

under Keyboards
Properties on Microsoft eHome...
Power management TAB
Make sure 'Allow this device to bring..." is checked
Properties on your keyboard
Power management TAB (if exists)
Change setting based on your preference
under Mice and other pointing devices
Properties on your mouse
Power management TAB (if exists)
Change setting based on your preference
5. Windows Changes

Apply windows updates that relate to 'ehome' - reboot

To not have a password prompt on resume (optional)

Right click on generic background
Select properties
'Screen Saver' TAB
'Power' button
'Advanced' TAB
Un-check Prompt for password when comeputer resumes from standby

6. Troubleshooting is a handy power test tool.
in Dos 'dumppo admin' will show your current power settings
'dumppo admin minsleep=S3' will force windows to go in to s3 when you do start -> Turn off -> Standby
Can't get the machine to S3 (only goes in to s1 - fans stay on) - Use the above tool to force an S3 setting "dumppo admin minsleep=s3"
When I try s3 Windows gives an error that ehome is blocking power save:
Make sure you have the IR receive plugged in to a USB port that has +5VSB set
Rumor is if you installed windows with your MB not set to do s3 you are hooped. If you had to change your MB power save settings you may have to do a re-install. MS apparently checks this on install, and puts a different dll in if no ACPI or s3 is found (I've alwasy had s1 or s3 on, has not been an issue)
If you don't have the power management tab, remove the device (all eHome devices) unplug USB fo rthe IR receiver, Reboot, plug devices back in - this should re-install with power management.
Unit goes to sleep and wakes right back up:
Something else is waking up the unit - unplug all USB devices with the unit on (except the IR receiver) and try to power off. If that works, add back other USB devices 1 by 1 (starting Keyboard, then mouse...) till you find the device waking up your machine.
My wireless Keyboard/Mouse was the cause, turning on the +5VSB power solved this.
Remove any extra PCI cards, add back 1 at a time
Keyboard or mouse movement wakes up PC - Double check step 4 above
Other devices are waking up system - check settings similar to step 4 above
On resume the system asks for password - Check screen saver settings make sure 'On Resume, Password Protect' is not checked
On resume I have to click on my username - Under Power option (ctrl panel, or display-.screen saver), make sure 'Prompt for password when...' is not checked
On resume I get a black screen - I've seen something about a patch for this, I think it was ATI related
On resume, my machine blue screens - you've got a bad driver... I had to re-build from scratch
On resume, my machien reboots - It's probaly blue screen with auto recover - re-build, add 1 driver at a time. start with Video card.

Hope that helps you.

If you find any typos, fixes or additions that I should add to this, let me know (direct email, not a reply) and I will edit it to try to keep it a good resource.

Special thanks to all on this board (ESP Crazy) for the info that lead to this.

2/4/2005 - Subsequent test I found that a load I did with S3 only set in bios - I could not power save. My device setting did not have the power tab. I re-loaded with the bios setting at (s1 & s3) and everything worked great (with above procedure)

4/8/2005 - I received a few questions from people on exactly how to edit the reg (at your own risk ;-)

Open Regedit - (start -> Run -> Regedit)

Expand the 'HKEY_Local_machine'

Expand 'System'

Expand 'CurrentControlSet'

right Click on 'Services' -> 'NEW' -> 'KEY'

Name the KEY 'USB'

right click on your new key 'USB' ->'NEW' - 'DWORD Value'

Name the dword 'USBBIOSx'

Close regedit

9/2/2005 - I just rebuilt my machine. The windows updates seemed to help fix things

Also made misc clean up / updates to the message."