Får ikke satt DMA-mode på DVD-ROM

Sponsorer:
Takk Takk:  0
Like Like:  0
Viser resultater 1 til 5 av 5
  1. #1
    Intermediate
    Medlem siden
    Dec 2002
    Poster
    874
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)

    Får ikke satt DMA-mode på DVD-ROM

    Jeg har lagt merke til at det hakker når jeg spiller av DVD på HTPCen (P4C@3.4). Dette skjer ikke hvis jeg spiller av DVD som er rippet til harddisken. I egenskaper for DVD-rom er det valgt "Use DMA if available", men i ruta under står det at det brukes PIO-mode. DVD-romen er en Pioneer DVD-103 slotin som jeg har brukt i flere PCer over noen år. Før var det ihvertfall et poeng å bruke DMA-mode for å unngå hakking. Jeg merket ihvertfall stor forskjell under Win98 med og uten DMA. Nå bruker jeg WinXP Pro, sevicepack 2. I og med at det var mulig å velge DMA før må det vel være mulig under WinXP også? Hakkingen forsvant da jeg prøvde en annen DVD-rom som jeg lånte, men jeg sjekket ikke om DMA-mode var i bruk da.

    Gunnar

  2. #2
    Intermediate Mastiff sin avatar
    Medlem siden
    Jul 2003
    Poster
    1,970
    Takk & like
    Nevnt
    1 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Ja, det er mulig og nødvendig. Først må det aktiveres i BIOS, deretter går du på IDE-kontrolleren (ikke enheten, som i Win98) og setter til DMA der.

  3. #3
    Intermediate
    Medlem siden
    Dec 2002
    Poster
    874
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Etter litt søking på nettet finner jeg ut at WinXP registrerer CRC-feil når en f eks prøver å spille en DVD med feil på f eks hakk. Etter hvert som det registreres feil vil WinXP redusere DMA-mode, og etter 6 feil vil kontrolleren kun bruke PIO-mode. Det er mulig å endre på verdier i registeret for å resette telleren, og ellers kan en også slette kontrolleren som DVD-romen er tikoblet. WinXP installerer den på nytt neste gang en rebooter, og problemet er borte for en stund. I WinXP Servicepack 2 er dette endret, slik at det må være 6 etterfølgende feil før DMA-mode endres.

    Jeg går ut fra at det er dette som har skjedd hos meg, men jeg rakk ikke å sjekke det i kveld. Verdt og merke seg hvis en plutselig får hakkete avspilling av DVD på HTPCen.

    Gunnar

  4. #4
    Intermediate
    Medlem siden
    Dec 2002
    Poster
    874
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Da kan jeg bekrefte at dette var problemet. Slettet secondary controlleren som DVD-romen var tilkoblet og rebootet. Måtte reboote to ganger før kontrolleren ble installert, men da fungerte alt som det skulle igjen. Ultra DMA-mode 2 istedetfor PIO, og ingen hakking mere.

    Gunnar

  5. #5
    Newcomer
    Medlem siden
    Jun 2005
    Poster
    23
    Takk & like
    Nevnt
    0 post(er)
    AVtorget feedback
    0
    (0% positive tilbakemeldinger)
    Gunnar: Jeg er (ganske) sikker på at jeg kjører Ultra DMA mode 2 istedet for PIO. Men i går hakket dvd`rom en vanvittig. Den gikk liksom ikke videre og låste seg. Da jeg puttet dvd`en i den vanlige dvd spilleren hoppet den bare forbi stedet som var hakk i platen. Er det noe mer man skal stille på for å unngå hakking?

Stikkord for denne tråden

Regler for innlegg

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg / tråder
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere meldingene dine
  •